Docker Engine before 1.6.1 allows local users to set arbitrary Linux Security Modules…
Priority LOW 18CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
Docker Engine before 1.6.1 allows local users to set arbitrary Linux Security Modules (LSM) and docker_t policies via an image that allows volumes to override files in /proc.
Why it matters now
EPSS 0.00567 47th percentileScored 2026-11-07
Fix Fixed github.com/docker/docker (Go): 1.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/docker/docker (Go) | before 1.6.1 | 1.6.1 | Patch available | GHSA-v4h8-794j-g8mm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/docker/docker (Go) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-v4h8-794j-g8mm
Remediation
- Fix · GHSA-v4h8-794j-g8mm github.com/docker/docker (Go) Fixed in 1.6.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3631
- 2026-10-03 Alias added: GHSA-v4h8-794j-g8mm
References
Other 7
- https://groups.google.com/forum/#%21searchin/docker-user/1.6.1/docker-user/47GZrihtr-4/nwgeOOFLexIJ
- 20150508 Docker 1.6.1 - Security Advisory [150507]
- http://packetstormsecurity.com/files/131835/Docker-Privilege-Escalation-Information-Disclosure.html
- https://github.com/moby/moby
- https://github.com/moby/moby/compare/769acfec2928c47a35da5357d854145b1036448d...b6a9dc399be31c531e3753104e10d74760ed75a2
- https://groups.google.com/forum/#!searchin/docker-user/1.6.1/docker-user/47GZrihtr-4/nwgeOOFLexIJ
- https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-3631
More Docker vulnerabilities
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2019-10626 In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code… CVSS 3.1CRITICAL 9.8
- TI-2014-07591 Docker 1.3.2 allows remote attackers to execute arbitrary code with root privileges via a… CVSS 2.0HIGH 10.0
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2014-07590 Path traversal vulnerability in Docker before 1.3.3 allows remote attackers to write to… CVSS 3.1HIGH 8.6
Sources
- CVE-2015-3631 · CVE Program
- CVE-2015-3631 · NVD
- FIRST EPSS
- GHSA-v4h8-794j-g8mm · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3631 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences