Cross-site scripting (XSS) vulnerability in Apache Struts before 2.3.20.
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Apache Struts before 2.3.20.
Why it matters now
EPSS 0.07533 94th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.20
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | before 2.3.20 | 2.3.20 | Patch available | GHSA-vwhv-j36g-5rm8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected before 2.3.20 Fixed in 2.3.20 Patch available GHSA-vwhv-j36g-5rm8
Remediation
- Fix · GHSA-vwhv-j36g-5rm8 org.apache.struts:struts2-core (Maven) Fixed in 2.3.20 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5169
- 2026-10-03 Alias added: GHSA-vwhv-j36g-5rm8
References
Advisory 6
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2015-5169 · CVE Program
- CVE-2015-5169 · NVD
- FIRST EPSS
- GHSA-vwhv-j36g-5rm8 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5169 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences