Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow remote attackers to conduct cross-site request forgery (CSRF) attacks on PWS and log a user into an arbitrary account by leveraging lack of CSRF checks.
Why it matters now
EPSS 0.00757 55th percentileScored 2026-11-07
Fix Fixed org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): 2.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | before 2.5.2 | 2.5.2 | Patch available | GHSA-mpv3-g527-fqrj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected before 2.5.2 Fixed in 2.5.2 Patch available GHSA-mpv3-g527-fqrj
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudfoundry:cf-release:*:*:*:*:*:*:*:* | before 216 | Vulnerable | CloudFoundry Foundation |
| cpe:2.3:a:pivotal_software:cloud_foundry_elastic_runtime:*:*:*:*:*:*:*:* | before 1.7.0 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* | before 2.5.2 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:cloudfoundry:cf-release:*:*:*:*:*:*:*:* Versions before 216 Vulnerable ·CloudFoundry Foundation
- cpe:2.3:a:pivotal_software:cloud_foundry_elastic_runtime:*:*:*:*:*:*:*:* Versions before 1.7.0 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* Versions before 2.5.2 Vulnerable ·Spring by Pivotal
Remediation
- Fix · GHSA-mpv3-g527-fqrj org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 2.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5170
- 2026-10-03 Alias added: GHSA-mpv3-g527-fqrj
References
Advisory 2
Sources
- CVE-2015-5170 · CVE Program
- CVE-2015-5170 · NVD
- FIRST EPSS
- GHSA-mpv3-g527-fqrj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences