Read the docs

Spring by Pivotal

Records146All Threatist records
Exploited (KEV)1In CISA KEV
CVSS critical30CVSS 9.0–10.0
CVSS high64CVSS 7.0–8.9

Exploited now

Spring by Pivotal records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

146 records

TI-2018-01178 CVE-2018-1273 · GHSA-4fq3-mr56-cg6r

Code injection in Spring Framework

Priority CRITICAL 100KEV

Spring Data Commons, versions prior to 1.13 to 1.13.10, 2.0 to 2.0.5, and older unsupported versions, contain a property binder vulnerability caused by improper neutralization of special elements.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.96956 Published 2018-04-11 Partial fix · 1.13.11, 2.0.6 CWE-94
TI-2018-01175 CVE-2018-1270 · GHSA-p5hg-3xm3-gcjg

Code injection in Spring Framework

Priority CRITICAL 88

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, allow applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.77476 Published 2018-04-06 Partial fix · 5.0.5.RELEASE, 4.3.16.RELEASE CWE-94
Priority HIGH 81

Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.7453 Published 2018-01-04 Fixed in 2.6.9.RELEASE, 3.0.1.RELEASE CWE-20
TI-2018-01180 CVE-2018-1275 · GHSA-3rmv-2pg5-xvqj

Code injection in Spring Framework

Priority HIGH 76

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.16 and older unsupported versions, allow applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.57414 Published 2018-04-11 Partial fix · 4.3.16.RELEASE, 5.0.5.RELEASE CWE-94
Priority HIGH 73

The SourceHttpMessageConverter in Spring MVC in Spring Framework before 3.2.5 and 4.0.0.M1 through 4.0.0.RC1 does not disable external entity resolution, which allows remote attackers to read arbitrary files, cause a den…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.9056 Published 2014-01-26 Partial fix · 3.2.5.RELEASE CWE-352
TI-2022-13602 CVE-2022-31683 · GHSA-5jp2-vwrj-99rf

Authorization bypass in Concourse

Priority MEDIUM 58

Concourse (7.x.y prior to 7.8.3 and 6.x.y prior to 6.7.9) contains an authorization bypass issue.

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00467 Published 2022-12-19 Fixed in 6.7.9, 7.8.3 CWE-639
Priority MEDIUM 55

Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versions contains a remote code execution vulnerability.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.10616 Published 2018-05-11 Partial fix · 2.3.3, 2.2.2 +2 CWE-94
TI-2018-01176 CVE-2018-1271 · GHSA-g8hw-794c-4j9g

Path traversal in Spring Framework

Priority MEDIUM 50

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, allow applications to configure Spring MVC to serve static resources (e.g.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.30338 Published 2018-04-06 Partial fix · 5.0.5, 4.3.15 CWE-22
TI-2019-02792 CVE-2019-3778 · GHSA-77rv-6vfw-x4gc

Open Redirect in spring-security-oauth2

Priority MEDIUM 46

Spring Security OAuth, versions 2.3 prior to 2.3.5, and 2.2 prior to 2.2.4, and 2.1 prior to 2.1.4, and 2.0 prior to 2.0.17, and older unsupported versions could be susceptible to an open redirector attack that can leak…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.16596 Published 2019-03-07 Fixed in 2.3.5.RELEASE, 2.0.17.RELEASE +2 CWE-601
Priority MEDIUM 46

Pivotal Application Service (PAS), versions 2.2.x prior to 2.2.12, 2.3.x prior to 2.3.7 and 2.4.x prior to 2.4.3, contain apps manager that uses a cloud controller proxy that fails to verify SSL certs.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01908 Published 2019-03-07 Fixed in 666.0.19, 665.0.26 +4 CWE-295
TI-2018-11240 CVE-2018-15761 · GHSA-292x-hjr8-226f

UAA Privilege Escalation

Priority MEDIUM 46

Cloud Foundry UAA release, versions prior to v64.0, and UAA, versions prior to 4.23.0, contains a validation error which allows for privilege escalation.

CVSS 3.0CRITICAL 9.9 Network Low privileges No interaction EPSS 0.01713 Published 2018-11-19 Fixed in 4.23.0, 64.0
Priority MEDIUM 46

Pivotal Cloud Foundry On Demand Services SDK, versions prior to 0.24 contain an insecure method of verifying credentials.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01748 Published 2018-11-19 Fixed in 0.24.0 CWE-307
Priority MEDIUM 46

Cloud Foundry Log Cache, versions prior to 1.1.1, logs its UAA client secret on startup as part of its envstruct report.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01808 Published 2018-10-05 Fixed in 1.1.1 CWE-532
Priority MEDIUM 46

An issue was discovered in Pivotal PCF Elastic Runtime 1.6.x versions prior to 1.6.60, 1.7.x versions prior to 1.7.41, 1.8.x versions prior to 1.8.23, and 1.9.x versions prior to 1.9.1.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02129 Published 2017-06-13 No fix listed CWE-20
Priority MEDIUM 46

The GemFire broker for Cloud Foundry 1.6.x before 1.6.5 and 1.7.x before 1.7.1 has multiple API endpoints which do not require authentication and could be used to gain access to the cluster managed by the broker.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02048 Published 2018-03-16 No fix listed CWE-287
Priority MEDIUM 45

Concourse, versions prior to 6.3.1 and 6.4.1, in installations which use the GitLab auth connector, is vulnerable to identity spoofing by way of configuring a GitLab account with the same full name as another user who is…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.01217 Published 2020-08-12 Fixed in 6.4.1, 6.3.1 +3 CWE-290
Priority MEDIUM 45

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain con…

CVSS 3.0CRITICAL 9.6 Network Low privileges No interaction EPSS 0.02153 Published 2018-10-18 Fixed in 2.0.16, 2.1.3 +2 CWE-269
Priority MEDIUM 45

An issue was discovered in Pivotal PCF Elastic Runtime 1.6.x versions prior to 1.6.65, 1.7.x versions prior to 1.7.48, 1.8.x versions prior to 1.8.28, and 1.9.x versions prior to 1.9.5.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01413 Published 2017-06-13 No fix listed CWE-532
Priority MEDIUM 45

Cloud Foundry Garden-Linux versions prior to v0.333.0 and Elastic Runtime 1.6.x version prior to 1.6.17 contain a flaw in managing container files during Docker image preparation that could be used to delete, corrupt or…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01605 Published 2017-05-25 No fix listed CWE-19
Priority MEDIUM 44

Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to save the SecurityContext if it is changed more than once in a single request.A…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.03286 Published 2021-02-23 Fixed in 5.4.4, 5.3.8 +1 CWE-269
Priority MEDIUM 44

Pivotal Apps Manager Release, versions 665.0.x prior to 665.0.28, versions 666.0.x prior to 666.0.21, versions 667.0.x prior to 667.0.7, contain an invitation service that accepts HTTP.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01053 Published 2019-04-24 Fixed in 666.0.21, 667.0.7 +1 CWE-300
Load more
Open these records in search →