Improper input validation in PowerDNS Authoritative Server
Priority MEDIUM 44CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via crafted query packets.
Why it matters now
EPSS 0.09021 95th percentileScored 2026-11-07
Fix Fixed PowerDNS Authoritative Server (PowerDNS): 3.4.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | PowerDNS Authoritative Server | 3.4 to before 3.4.6 | 3.4.6 | Patch available | CNA |
- PowerDNS Authoritative Server VendorPowerDNS Affected 3.4 to before 3.4.6 Fixed in 3.4.6 Patch available CNA
Remediation
- Fix · CNA PowerDNS Authoritative Server (PowerDNS) Fixed in 3.4.6
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5230
- 2026-10-03 Alias added: GHSA-q4mr-9hrx-q3wc
References
More PowerDNS Authoritative vulnerabilities
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2015-04466 PowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to… CVSS 2.0MEDIUM 5.0
- TI-2016-04702 PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a… CVSS 3.0HIGH 7.5
- TI-2026-25990 Incomplete domain name sanitization during CVSS 3.1CRITICAL 9.8
- TI-2020-15157 An issue was discovered in PowerDNS Authoritative through 4.3.0 when… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-5230 · CVE Program
- CVE-2015-5230 · NVD
- FIRST EPSS
- GHSA-q4mr-9hrx-q3wc · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5230 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences