Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority HIGH 74
The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server 3.2.x, 3.3.x before 3.3.2, and 3.4.x before 3.4.4 allows remote attackers to ca…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.78725 · Published 2015-05-18 · No fix listed CWE-399
Priority HIGH 69
PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by sending a specific query (QTYPE 65535) that causes an out-of-bounds exception.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.64857 · Published 2021-07-27 · No fix listed CWE-119
Priority HIGH 68
PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a .
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.62982 · Published 2016-09-21 · No fix listed CWE-399
Priority HIGH 67
An issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending a DNS query can trigger an out-of-bounds memory read while computing the hash of the query for a packet cache lookup, poss…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.58577 · Published 2018-12-03 · No fix listed CWE-125
Priority MEDIUM 64
An issue has been found in the parsing of authoritative answers in PowerDNS Recursor before 4.0.8, leading to a NULL pointer dereference when parsing a specially crafted answer containing a CNAME of a different class tha…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.51353 · Published 2018-07-27 · No fix listed CWE-476
Priority MEDIUM 60
PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote attackers to cause a denial of service ("performance degradations") via a large or infinite number of referrals, as demonstrated by r…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.68875 · Published 2014-12-10 · No fix listed CWE-399
Priority MEDIUM 60
Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.17572 · Published 2010-01-08 · No fix listed CWE-119
Priority MEDIUM 59
An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.24495 · Published 2020-05-19 · No fix listed CWE-125
Priority MEDIUM 59
PowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to cause a denial of service (assertion failure and server crash) via crafted query packets.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.67456 · Published 2015-11-17 · No fix listed CWE-20
Priority MEDIUM 57
PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a denial of service (backend CPU consumption) via a long qname.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.30631 · Published 2016-09-21 · No fix listed CWE-399
Priority MEDIUM 52
A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.12632 · Published 2019-03-21 · No fix listed CWE-20
Priority MEDIUM 49
A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS query that retrieves DS records for a misconfigured domain, because QName minimization is used in QM fallback mode.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.07521 · Published 2023-01-21 · No fix listed CWE-674
Priority MEDIUM 48
An attacker can send a notify request that causes a new secondary domain to be added to the bind backend, but causes said backend to update its configuration to an invalid one, leading to the backend no longer able to ru…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00383 · Published 2026-04-22 · Fixed in 5.0.4, 4.9.14 CWE-94
Priority MEDIUM 48
An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03157 · Published 2020-10-02 · No fix listed CWE-415
Priority MEDIUM 47
The label decompression functionality in PowerDNS Recursor before 3.6.4 and 3.7.x before 3.7.3 and Authoritative (Auth) Server before 3.3.3 and 3.4.x before 3.4.5 allows remote attackers to cause a denial of service (CPU…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.11284 · Published 2015-11-02 · No fix listed CWE-399
Priority MEDIUM 45
Unspecified vulnerability in PowerDNS Recursor before 3.1.7.2 allows remote attackers to spoof DNS data via crafted zones.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.10263 · Published 2010-01-08 · No fix listed
Priority MEDIUM 44
An attacker might be able to trigger an out-of-bounds read by sending a crafted DNS response packet, when custom Lua code uses newDNSPacketOverlay to parse DNS packets.
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.01068 · Published 2026-03-31 · Fixed in 1.9.12, 2.0.3 CWE-126
Priority MEDIUM 44
The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via crafted query packets.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.09021 · Published 2020-01-15 · Fixed in 3.4.6 CWE-20
Priority MEDIUM 44
Buffer overflow in PowerDNS Recursor 3.1.3 and earlier might allow remote attackers to execute arbitrary code via a malformed TCP DNS query that prevents Recursor from properly calculating the TCP DNS query length.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.08788 · Published 2006-11-14 · No fix listed
Priority MEDIUM 43
When DNSdist is configured to provide DoH via the nghttp2 provider, an attacker can cause a denial of service by crafting a DoH exchange that triggers an illegal memory access (double-free) and crash of DNSdist, causing…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02289 · Published 2025-04-29 · Fixed in 1.9.9 CWE-416
Priority MEDIUM 43
An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4 and 4.0.4, allowing a remote, unauthenticated attacker to cause an abnormal CPU usage load on the PowerDNS server by sending…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.07294 · Published 2018-09-11 · No fix listed CWE-20
Priority MEDIUM 42
An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before 4.3.5.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.06543 · Published 2020-10-16 · No fix listed
Priority MEDIUM 42
An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the answer section of responses received from authoritative servers with the AA flag not set were not properly validated, allowing…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00368 · Published 2019-01-29 · Fixed in 4.1.9 CWE-345
Load more