providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before…
Priority LOW 28CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · Partial
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).
Why it matters now
EPSS 0.01493 74th percentileScored 2026-11-07
Fix Partial ipsilon (PyPI): 1.0.2, 1.2.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ipsilon (PyPI) | 0.1.0 to before 1.0.2 | 1.0.2 | Patch available | GHSA-9qp4-79q8-58pr |
| — | ipsilon (PyPI) | 1.1.0 to before 1.2.0 | 1.2.0 | Patch available | GHSA-9qp4-79q8-58pr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ipsilon (PyPI) Vendor— Affected 0.1.0 to before 1.0.2 Fixed in 1.0.2 Patch available GHSA-9qp4-79q8-58pr
- ipsilon (PyPI) Vendor— Affected 1.1.0 to before 1.2.0 Fixed in 1.2.0 Patch available GHSA-9qp4-79q8-58pr
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ipsilon_project:ipsilon:0.1.0:*:*:*:*:*:*:* | 0.1.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:0.3.0:*:*:*:*:*:*:* | 0.3.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:0.4.0:*:*:*:*:*:*:* | 0.4.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:0.5.0:*:*:*:*:*:*:* | 0.5.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:0.6.0:*:*:*:*:*:*:* | 0.6.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Ipsilon Project |
- cpe:2.3:a:ipsilon_project:ipsilon:0.1.0:*:*:*:*:*:*:* Versions 0.1.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:0.3.0:*:*:*:*:*:*:* Versions 0.3.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:0.4.0:*:*:*:*:*:*:* Versions 0.4.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:0.5.0:*:*:*:*:*:*:* Versions 0.5.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:0.6.0:*:*:*:*:*:*:* Versions 0.6.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Ipsilon Project
Remediation
- Fix · GHSA-9qp4-79q8-58pr ipsilon (PyPI) Fixed in 1.0.2 Advisory →
- Fix · GHSA-9qp4-79q8-58pr ipsilon (PyPI) Fixed in 1.2.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5301
- 2026-10-03 Alias added: GHSA-9qp4-79q8-58pr
References
Advisory 4
Other 7
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.2
- [oss-security] 20151027 Multiple CVE info for Ipsilon
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.1.1
- https://pagure.io/ipsilon/9dec97c3c83928d231ea10f4160523a13803e594
- https://bugzilla.redhat.com/show_bug.cgi?id=1271530
- https://github.com/ipsilon-project/ipsilon
- https://github.com/pypa/advisory-database/tree/main/vulns/ipsilon/PYSEC-2015-42.yaml
More Ipsilon Project Ipsilon vulnerabilities
- TI-2016-07100 A vulnerability in ipsilon 2.0 before 2.0.2, 1.2 before 1.2.1, 1.1 before 1.1.2, and 1.0… CVSS 3.0CRITICAL 9.1
- TI-2015-04379 providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2015-5301 · CVE Program
- CVE-2015-5301 · NVD
- FIRST EPSS
- GHSA-9qp4-79q8-58pr · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5301 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences