A vulnerability in ipsilon 2.0 before 2.0.2, 1.2 before 1.2.1, 1.1 before 1.1.2, and 1.0…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-384.
Summary
A vulnerability in ipsilon 2.0 before 2.0.2, 1.2 before 1.2.1, 1.1 before 1.1.2, and 1.0 before 1.0.3 was found that allows attacker to log out active sessions of other users. This issue is related to how it tracks sessions, and allows an unauthenticated attacker to view and terminate active sessions from other users. It is also called a "SAML2 multi-session vulnerability."
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ipsilon (PyPI) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-376m-3rm2-9jm6 |
| — | ipsilon (PyPI) | 1.2.0 to before 1.2.1 | 1.2.1 | Patch available | GHSA-376m-3rm2-9jm6 |
| — | ipsilon (PyPI) | 1.1.0 to before 1.1.2 | 1.1.2 | Patch available | GHSA-376m-3rm2-9jm6 |
| — | ipsilon (PyPI) | 1.0.0 to before 1.0.3 | 1.0.3 | Patch available | GHSA-376m-3rm2-9jm6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ipsilon (PyPI) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-376m-3rm2-9jm6
- ipsilon (PyPI) Vendor— Affected 1.2.0 to before 1.2.1 Fixed in 1.2.1 Patch available GHSA-376m-3rm2-9jm6
- ipsilon (PyPI) Vendor— Affected 1.1.0 to before 1.1.2 Fixed in 1.1.2 Patch available GHSA-376m-3rm2-9jm6
- ipsilon (PyPI) Vendor— Affected 1.0.0 to before 1.0.3 Fixed in 1.0.3 Patch available GHSA-376m-3rm2-9jm6
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ipsilon_project:ipsilon:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Ipsilon Project |
| cpe:2.3:a:ipsilon_project:ipsilon:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Ipsilon Project |
- cpe:2.3:a:ipsilon_project:ipsilon:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Ipsilon Project
- cpe:2.3:a:ipsilon_project:ipsilon:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Ipsilon Project
Remediation
- Fix · GHSA-376m-3rm2-9jm6 ipsilon (PyPI) Fixed in 2.0.2 Advisory →
- Fix · GHSA-376m-3rm2-9jm6 ipsilon (PyPI) Fixed in 1.2.1 Advisory →
- Fix · GHSA-376m-3rm2-9jm6 ipsilon (PyPI) Fixed in 1.1.2 Advisory →
- Fix · GHSA-376m-3rm2-9jm6 ipsilon (PyPI) Fixed in 1.0.3 Advisory →
Red Hat 1 advisory
- RHSA-2016:2809 Released 2016-11-21 · Red Hat rating Importantipsilon security update
- Red Hat Enterprise Linux Server (v. 7) ipsilon-1.0.0-13.el7_3, ipsilon-authform-1.0.0-13.el7_3, ipsilon-authgssapi-1.0.0-13.el7_3 +9
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2016:2809 |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8638
- 2026-10-03 Alias added: GHSA-376m-3rm2-9jm6
References
Advisory 5
Other 11
- https://ipsilon-project.org/release/2.1.0.html
- https://github.com/ipsilon-project/ipsilon/commit/1c48414877fc110652b6078a29529972c7ec9122
- https://github.com/ipsilon-project/ipsilon/commit/64fc366c054fc6af1d9d2692902db169884b5f78
- https://github.com/ipsilon-project/ipsilon/commit/a33303b6beb5c316d7c18b23566b7666a4e307a4
- https://github.com/ipsilon-project/ipsilon/commit/b4744a92d4fa7f6d7ade0ae2d99a2dc0ea94734d
- https://access.redhat.com/errata/RHSA-2016:2809
- https://access.redhat.com/security/cve/CVE-2016-8638
- https://bugzilla.redhat.com/show_bug.cgi?id=1392829
- https://github.com/ipsilon-project/ipsilon
- https://github.com/pypa/advisory-database/tree/main/vulns/ipsilon/PYSEC-2026-360.yaml
- https://pypi.org/project/ipsilon
More Ipsilon Project Ipsilon vulnerabilities
- TI-2015-04456 providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before… CVSS 2.0MEDIUM 5.5
- TI-2015-04379 providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2016-8638 · CVE Program
- CVE-2016-8638 · NVD
- FIRST EPSS
- GHSA-376m-3rm2-9jm6 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-8638 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences