Read the docs
TI-2015-06263 Aliases CVE-2015-7536GHSA-x3p3-929j-pq66

Cross-site scripting (XSS) vulnerability in Jenkins before 1.640 and LTS before 1.625.2…

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in Jenkins before 1.640 and LTS before 1.625.2 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors related to workspaces and archived artifacts.

Why it matters now

EPSS 0.01251 69th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 1.640, 1.625.2Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)1.626 to before 1.6401.640Patch availableGHSA-x3p3-929j-pq66
—org.jenkins-ci.main:jenkins-core (Maven)before 1.625.21.625.2Patch availableGHSA-x3p3-929j-pq66
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.626 to before 1.640 Fixed in 1.640 Patch available GHSA-x3p3-929j-pq66
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.625.2 Fixed in 1.625.2 Patch available GHSA-x3p3-929j-pq66

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 1.625.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 1.639VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 1.625.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.639 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-x3p3-929j-pq66 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.640 Advisory →
  • Fix · GHSA-x3p3-929j-pq66 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.625.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 2AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-7536
  2. 2026-10-03 Alias added: GHSA-x3p3-929j-pq66

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources