Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.x before 3.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) Locale or (2) FailedLoginCount parameter to admin/security/EditForm/field/Members/item/new/ItemEditForm.
Why it matters now
EPSS 0.01535 74th percentileScored 2026-11-07
Fix Fixed silverstripe/cms (Packagist): 3.1.16, 3.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/cms (Packagist) | before 3.1.16 | 3.1.16 | Patch available | GHSA-gvc8-xjfp-6569 |
| — | silverstripe/cms (Packagist) | 3.2.0 to before 3.2.1 | 3.2.1 | Patch available | GHSA-gvc8-xjfp-6569 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/cms (Packagist) Vendor— Affected before 3.1.16 Fixed in 3.1.16 Patch available GHSA-gvc8-xjfp-6569
- silverstripe/cms (Packagist) Vendor— Affected 3.2.0 to before 3.2.1 Fixed in 3.2.1 Patch available GHSA-gvc8-xjfp-6569
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* | up to 3.1.15 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* Versions up to 3.1.15 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-gvc8-xjfp-6569 silverstripe/cms (Packagist) Fixed in 3.1.16 Advisory →
- Fix · GHSA-gvc8-xjfp-6569 silverstripe/cms (Packagist) Fixed in 3.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8606
- 2026-10-03 Alias added: GHSA-gvc8-xjfp-6569
References
Advisory 2
Other 6
- [oss-security] 20151217 Cross site scripting vulnerability (XSS) in SilverStripe CMS & Framework v3.2.0
- [oss-security] 20151217 Re: Cross site scripting vulnerability (XSS) in SilverStripe CMS & Framework v3.2.0
- [oss-security] 20151218 [FD] [CVE-2015-8606] SilverStripe CMS & Framework v3.2.0 - Cross-Site Scripting Vulnerability
- 20151213 SilverStripe CMS & Framework v3.2.0 - Cross-Site Scripting Vulnerability
- https://cybersecurityworks.com/zerodays/cve-2015-8606-silverstripe.html
- https://github.com/silverstripe/silverstripe-cms
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2011-04272 code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow… CVSS 2.0MEDIUM 6.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
Sources
- CVE-2015-8606 · CVE Program
- CVE-2015-8606 · NVD
- FIRST EPSS
- GHSA-gvc8-xjfp-6569 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences