The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean…
Priority MEDIUM 48CWE-254Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.
Why it matters now
EPSS 0.03559 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed uglify-js (npm): 2.4.24uglifier (RubyGems): 2.7.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | uglify-js (npm) | before 2.4.24 | 2.4.24 | Patch available | GHSA-34r7-q49f-h37c |
| — | uglifier (RubyGems) | before 2.7.2 | 2.7.2 | Patch available | GHSA-34r7-q49f-h37c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- uglify-js (npm) Vendor— Affected before 2.4.24 Fixed in 2.4.24 Patch available GHSA-34r7-q49f-h37c
- uglifier (RubyGems) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-34r7-q49f-h37c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:uglifyjs_project:uglifyjs:*:*:*:*:*:node.js:*:* | before 2.4.24 | Vulnerable | Uglifyjs Project |
- cpe:2.3:a:uglifyjs_project:uglifyjs:*:*:*:*:*:node.js:*:* Versions before 2.4.24 Vulnerable ·Uglifyjs Project
Remediation
- Fix · GHSA-34r7-q49f-h37c uglify-js (npm) Fixed in 2.4.24 Advisory →
- Fix · GHSA-34r7-q49f-h37c uglifier (RubyGems) Fixed in 2.7.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8857
- 2026-10-03 Alias added: GHSA-34r7-q49f-h37c
References
Advisory 2
Other 6
- https://github.com/mishoo/UglifyJS2/issues/751
- https://github.com/lautis/uglifier/commit/4677bfe38142937ff952f95605bcec4618892c3e
- https://github.com/mishoo/UglifyJS2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uglifier/CVE-2015-8857.yml
- https://web.archive.org/web/20200227190830/http://www.securityfocus.com/bid/96410
- https://zyan.scripts.mit.edu/blog/backdooring-js
More Uglifyjs Project Uglifyjs vulnerabilities
- TI-2022-17513 Prototype pollution vulnerability in function DEFNODE in ast.js in mishoo UglifyJS 3.13.2… CVSS 3.1CRITICAL 9.8
- TI-2015-07288 The uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of… CVSS 3.0HIGH 7.5
Sources
- CVE-2015-8857 · CVE Program
- CVE-2015-8857 · NVD
- FIRST EPSS
- GHSA-34r7-q49f-h37c · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8857 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences