The uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of…
Priority LOW 37CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of service (CPU consumption) via crafted input in a parse call, aka a "regular expression denial of service (ReDoS)."
Why it matters now
EPSS 0.02358 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed uglify-js (npm): 2.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | uglify-js (npm) | before 2.6.0 | 2.6.0 | Patch available | GHSA-c9f4-xj24-8jqx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- uglify-js (npm) Vendor— Affected before 2.6.0 Fixed in 2.6.0 Patch available GHSA-c9f4-xj24-8jqx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:uglifyjs_project:uglifyjs:*:*:*:*:*:node.js:*:* | up to 2.5.0 | Vulnerable | Uglifyjs Project |
- cpe:2.3:a:uglifyjs_project:uglifyjs:*:*:*:*:*:node.js:*:* Versions up to 2.5.0 Vulnerable ·Uglifyjs Project
Remediation
- Fix · GHSA-c9f4-xj24-8jqx uglify-js (npm) Fixed in 2.6.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8858
- 2026-10-03 Alias added: GHSA-c9f4-xj24-8jqx
References
More Uglifyjs Project Uglifyjs vulnerabilities
- TI-2022-17513 Prototype pollution vulnerability in function DEFNODE in ast.js in mishoo UglifyJS 3.13.2… CVSS 3.1CRITICAL 9.8
- TI-2015-07287 The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-8858 · CVE Program
- CVE-2015-8858 · NVD
- FIRST EPSS
- GHSA-c9f4-xj24-8jqx · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8858 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences