Uncontrolled resource consumption in HackerOne hapi node module
Priority LOW 37CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised. Instead of sending a HTTP 500 error back to the sender, hapi node module before 11.1.3 will continue to hold the socket open until timed out (default node timeout is 2 minutes).
Why it matters now
EPSS 0.02063 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed hapi node module (HackerOne): 11.1.3hapi (npm): 11.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | hapi node module | before 11.1.3 | 11.1.3 | Patch available | CNA |
| — | hapi (npm) | before 11.1.3 | 11.1.3 | Patch available | GHSA-rc8h-3fv6-pxv8 |
- hapi node module VendorHackerOne Affected before 11.1.3 Fixed in 11.1.3 Patch available CNA
- hapi (npm) Vendor— Affected before 11.1.3 Fixed in 11.1.3 Patch available GHSA-rc8h-3fv6-pxv8
Remediation
- Fix · CNA hapi node module (HackerOne) Fixed in 11.1.3
- Fix · GHSA-rc8h-3fv6-pxv8 hapi (npm) Fixed in 11.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-9241
- 2026-10-03 Alias added: GHSA-rc8h-3fv6-pxv8
References
Advisory 3
More hapijs Hapi vulnerabilities
- TI-2017-11738 Uncontrolled resource consumption in HackerOne hapi node module CVSS 3.0HIGH 7.5
- TI-2015-07622 Improper access control in HackerOne hapi node module CVSS 3.0MEDIUM 5.9
- TI-2015-07616 Improper access control in HackerOne hapi node module CVSS 3.0MEDIUM 5.3
Sources
- CVE-2015-9241 · CVE Program
- CVE-2015-9241 · NVD
- FIRST EPSS
- GHSA-rc8h-3fv6-pxv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences