Read the docs

hapijs

Records22All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

hapijs records in CISA KEV

No hapijs vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

22 records

Priority MEDIUM 61

joi before versions 17.13.8 and 18.2.9 contains a prototype pollution vulnerability in the messages compilation function that accepts __proto__ as an error code.

CVSS 4.0MEDIUM 6.3 Network No auth No interaction EPSS 0.00389 Published 2026-09-13 Partial fix · 17.13.8, 18.2.9 CWE-1321
Priority MEDIUM 45

hoek node module before 4.2.0 and 5.0.x before 5.0.3 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via 'merge' and 'applyToDefaults' functions, which allows a malicious user to modify the pro…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.0419 Published 2018-03-30 Partial fix · 5.0.3, 4.2.1 CWE-471
Priority MEDIUM 44

@hapi/content from 6.0.1 before 6.0.3 contains a regular expression denial of service vulnerability in Content.disposition() caused by an incomplete fix for CVE-2026-35213.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00466 Published 2026-10-23 Fixed in 6.0.3 CWE-1333
Priority MEDIUM 44

joi (npm package `joi`, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the `Joi.string().isoDate()` validation rule.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00582 Published 2026-09-16 Partial fix · 17.13.7, 18.2.6 CWE-1333
Priority LOW 28

Joi 17.13.6 before 17.13.9 and 18.2.5 before 18.3.1 contains a prototype pollution vulnerability in lib/messages.js compile() and merge() that fails to reject a __proto__ language key.

CVSS 4.0MEDIUM 6.3 Network No auth No interaction EPSS 0.0033 Published 2026-11-04 Fixed in 17.13.9, 18.3.1 CWE-1321
Priority LOW 28

When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher level config included security restrictions (like origin), a higher level config tha…

CVSS 3.0MEDIUM 5.9 Network No auth No interaction EPSS 0.01003 Published 2018-05-29 Fixed in 11.1.4 CWE-284
Priority LOW 27

Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden.

CVSS 3.0MEDIUM 5.3 Network No auth No interaction EPSS 0.01516 Published 2018-05-31 Fixed in 11.0.0 CWE-284
Open these records in search →