Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.
Why it matters now
EPSS 0.01357 71st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed nodebb (npm): 0.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nodebb (npm) | before 0.8.2 | 0.8.2 | Patch available | GHSA-72fv-qgj6-2w2p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nodebb (npm) Vendor— Affected before 0.8.2 Fixed in 0.8.2 Patch available GHSA-72fv-qgj6-2w2p
Remediation
- Fix · GHSA-72fv-qgj6-2w2p nodebb (npm) Fixed in 0.8.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-9286
- 2026-10-03 Alias added: GHSA-72fv-qgj6-2w2p
References
More Nodebb vulnerabilities
- TI-2023-23124 A remote code execution (RCE) vulnerability in the xmlrpc.php endpoint of NodeBB Inc… CVSS 3.1CRITICAL 9.8
- TI-2022-22808 Account takeover via prototype vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-42173 NodeBB - ActivityPub Author Spoofing via Unvalidated attributedTo Mapped to Local User CVSS 4.0HIGH 8.7
- TI-2025-32286 NodeBB v4.3.0 is vulnerable to SQL injection in its search-categories API endpoint… CVSS 3.1HIGH 8.6
- TI-2023-14416 NodeBB Pre-Authentication Denial-of-Service CVSS 3.1HIGH 7.5
- TI-2022-16499 Account takeover via SSO plugins in NodeBB CVSS 3.1HIGH 8.8
Sources
- CVE-2015-9286 · CVE Program
- CVE-2015-9286 · NVD
- FIRST EPSS
- GHSA-72fv-qgj6-2w2p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences