Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed…
Priority HIGH 70CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.
Why it matters now
EPSS 0.52351 98th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by the CNA and NVD
Fix Fixed org.apache.portals.jetspeed-2:jetspeed (Maven): 2.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.portals.jetspeed-2:jetspeed (Maven) | before 2.3.1 | 2.3.1 | Patch available | GHSA-88f6-79x2-xqf3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.portals.jetspeed-2:jetspeed (Maven) Vendor— Affected before 2.3.1 Fixed in 2.3.1 Patch available GHSA-88f6-79x2-xqf3
Remediation
- Fix · GHSA-88f6-79x2-xqf3 org.apache.portals.jetspeed-2:jetspeed (Maven) Fixed in 2.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0710
- 2026-10-03 Alias added: GHSA-88f6-79x2-xqf3
References
Exploit 3
Advisory 2
More Apache Jetspeed vulnerabilities
- TI-2016-00638 Directory traversal vulnerability in the Import/Export function in the Portal Site… CVSS 3.0HIGH 7.2
- TI-2016-01982 The User Manager service in Apache Jetspeed before 2.3.1 does not properly restrict… CVSS 3.0HIGH 7.5
- TI-2022-14168 Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues CVSS 3.1CRITICAL 9.8
- TI-2016-00641 Cross-site scripting (XSS) vulnerability in Apache Jetspeed before 2.3.1 allows remote… CVSS 3.0MEDIUM 6.1
- TI-2016-00640 Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2016-0710 · CVE Program
- CVE-2016-0710 · NVD
- FIRST EPSS
- GHSA-88f6-79x2-xqf3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences