Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow…
Priority LOW 33CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow remote attackers to inject arbitrary web script or HTML via the title parameter when adding a (1) link, (2) page, or (3) folder resource.
Why it matters now
EPSS 0.03065 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.portals.jetspeed-2:jetspeed-commons (Maven): 2.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.portals.jetspeed-2:jetspeed-commons (Maven) | before 2.3.1 | 2.3.1 | Patch available | GHSA-5pgm-9g57-3wc7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.portals.jetspeed-2:jetspeed-commons (Maven) Vendor— Affected before 2.3.1 Fixed in 2.3.1 Patch available GHSA-5pgm-9g57-3wc7
Remediation
- Fix · GHSA-5pgm-9g57-3wc7 org.apache.portals.jetspeed-2:jetspeed-commons (Maven) Fixed in 2.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0711
- 2026-10-03 Alias added: GHSA-5pgm-9g57-3wc7
References
More Apache Jetspeed vulnerabilities
- TI-2016-00638 Directory traversal vulnerability in the Import/Export function in the Portal Site… CVSS 3.0HIGH 7.2
- TI-2016-00639 Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed… CVSS 3.0HIGH 8.8
- TI-2016-01982 The User Manager service in Apache Jetspeed before 2.3.1 does not properly restrict… CVSS 3.0HIGH 7.5
- TI-2022-14168 Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues CVSS 3.1CRITICAL 9.8
- TI-2016-00641 Cross-site scripting (XSS) vulnerability in Apache Jetspeed before 2.3.1 allows remote… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2016-0711 · CVE Program
- CVE-2016-0711 · NVD
- FIRST EPSS
- GHSA-5pgm-9g57-3wc7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences