Cross-site scripting (XSS) vulnerability in the search_pagination function in…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.
Why it matters now
EPSS 0.01568 75th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.8.10, 2.9.4, 3.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.8 to before 2.8.10 | 2.8.10 | Patch available | GHSA-gj2j-ppjq-9pjg |
| — | moodle/moodle (Packagist) | 2.9 to before 2.9.4 | 2.9.4 | Patch available | GHSA-gj2j-ppjq-9pjg |
| — | moodle/moodle (Packagist) | 3.0 to before 3.0.2 | 3.0.2 | Patch available | GHSA-gj2j-ppjq-9pjg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.8 to before 2.8.10 Fixed in 2.8.10 Patch available GHSA-gj2j-ppjq-9pjg
- moodle/moodle (Packagist) Vendor— Affected 2.9 to before 2.9.4 Fixed in 2.9.4 Patch available GHSA-gj2j-ppjq-9pjg
- moodle/moodle (Packagist) Vendor— Affected 3.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-gj2j-ppjq-9pjg
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* | 22 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* | 23 | Vulnerable | Fedoraproject |
| cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | Moodle |
- cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
- cpe:2.3:a:moodle:moodle:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·Moodle
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* | 2.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* | 2.8.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.8.8:*:*:*:*:*:*:* Versions 2.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.8.9:*:*:*:*:*:*:* Versions 2.8.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-gj2j-ppjq-9pjg moodle/moodle (Packagist) Fixed in 2.8.10 Advisory →
- Fix · GHSA-gj2j-ppjq-9pjg moodle/moodle (Packagist) Fixed in 2.9.4 Advisory →
- Fix · GHSA-gj2j-ppjq-9pjg moodle/moodle (Packagist) Fixed in 3.0.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0725
- 2026-10-03 Alias added: GHSA-gj2j-ppjq-9pjg
References
Advisory 4
Sources
- CVE-2016-0725 · CVE Program
- CVE-2016-0725 · NVD
- FIRST EPSS
- GHSA-gj2j-ppjq-9pjg · GitHub Advisory Database · CC BY 4.0
- CVE-2016-0725 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences