Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a…
Priority MEDIUM 50CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.
Why it matters now
EPSS 0.08884 95th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.20.3, 2.3.24.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 2.3.20.3 | 2.3.20.3 | Patch available | GHSA-876p-4wgc-75rx |
| — | org.apache.struts:struts2-core (Maven) | 2.3.24 to before 2.3.24.3 | 2.3.24.3 | Patch available | GHSA-876p-4wgc-75rx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.3.20.3 Fixed in 2.3.20.3 Patch available GHSA-876p-4wgc-75rx
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.24 to before 2.3.24.3 Fixed in 2.3.24.3 Patch available GHSA-876p-4wgc-75rx
Remediation
- Fix · GHSA-876p-4wgc-75rx org.apache.struts:struts2-core (Maven) Fixed in 2.3.20.3 Advisory →
- Fix · GHSA-876p-4wgc-75rx org.apache.struts:struts2-core (Maven) Fixed in 2.3.24.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat JBoss Fuse Service Works 6
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0785
- 2026-10-03 Alias added: GHSA-876p-4wgc-75rx
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2016-0785 · CVE Program
- CVE-2016-0785 · NVD
- FIRST EPSS
- GHSA-876p-4wgc-75rx · GitHub Advisory Database · CC BY 4.0
- CVE-2016-0785 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences