Read the docs
TI-2016-02285 Aliases CVE-2016-2537GHSA-f522-ffg8-j8r6

The is-my-json-valid package before 2.12.4 for Node.js has an incorrect…

Priority LOW 37CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.

Summary

The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.

Why it matters now

EPSS 0.01849 79th percentileScored 2026-11-07
Fix Fixed is-my-json-valid (npm): 2.12.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—is-my-json-valid (npm)before 2.12.42.12.4Patch availableGHSA-f522-ffg8-j8r6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • is-my-json-valid (npm) Vendor— Affected before 2.12.4 Fixed in 2.12.4 Patch available GHSA-f522-ffg8-j8r6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:is_my_json_valid_project:is_my_json_valid:*:*:*:*:*:node.js:*:*up to 2.12.3VulnerableIs My Json Valid Project
  • cpe:2.3:a:is_my_json_valid_project:is_my_json_valid:*:*:*:*:*:node.js:*:* Versions up to 2.12.3 Vulnerable ·Is My Json Valid Project

Remediation

  • Fix · GHSA-f522-ffg8-j8r6 is-my-json-valid (npm) Fixed in 2.12.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-2537
  2. 2026-10-03 Alias added: GHSA-f522-ffg8-j8r6

References

Sources