Access control flaw in Pivotal Cloud Foundry
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The UAA reset password flow in Cloud Foundry release v236 and earlier versions, UAA release v3.3.0 and earlier versions, all versions of Login-server, UAA release v10 and earlier versions and Pivotal Elastic Runtime versions prior to 1.7.2 is vulnerable to a brute force attack due to multiple active codes at a given time. This vulnerability is applicable only when using the UAA internal user store for authentication. Deployments enabled for integration via SAML or LDAP are not affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | Cloud Foundry | release v236 and earlier versions; UAA release v3.3.0 and earlier versions; All versions of Login-server; UAA release v10 and earlier versions; Elastic Runtime versions prior to 1.7.2 | — | No fix listed | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | before 3.3.0.1 | 3.3.0.1 | Patch available | GHSA-fm5c-2rwc-887w |
- Cloud Foundry VendorPivotal Affected release v236 and earlier versions; UAA release v3.3.0 and earlier versions; All versions of Login-server; UAA release v10 and earlier versions; Elastic Runtime versions prior to 1.7.2 Fixed in — No fix listed CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected before 3.3.0.1 Fixed in 3.3.0.1 Patch available GHSA-fm5c-2rwc-887w
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudfoundry:cloud_foundry_uaa_bosh:*:*:*:*:*:*:*:* | up to 10 | Vulnerable | CloudFoundry Foundation |
| cpe:2.3:a:pivotal_software:cloud_foundry:*:*:*:*:*:*:*:* | up to 236 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_elastic_runtime:*:*:*:*:*:*:*:* | up to 1.7.1 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* | up to 3.3.0 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:login-server:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:cloudfoundry:cloud_foundry_uaa_bosh:*:*:*:*:*:*:*:* Versions up to 10 Vulnerable ·CloudFoundry Foundation
- cpe:2.3:a:pivotal_software:cloud_foundry:*:*:*:*:*:*:*:* Versions up to 236 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_elastic_runtime:*:*:*:*:*:*:*:* Versions up to 1.7.1 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:login-server:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Spring by Pivotal
Remediation
- Fix · GHSA-fm5c-2rwc-887w org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 3.3.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3084
- 2026-10-03 Alias added: GHSA-fm5c-2rwc-887w
References
Other 8
- https://github.com/cloudfoundry/uaa/commit/14350228989e2aee900b8d48a848293bb5152b6f
- https://github.com/cloudfoundry/uaa/commit/1d3ad7399d010f6a29dc3bf8139d792121301ab8
- https://github.com/cloudfoundry/uaa/commit/460627ed419e4227b10ff121248b3ffc009011a9
- https://github.com/cloudfoundry/uaa/commit/4a119d314744460ed56bcd740b2e913bf3f560c1
- https://github.com/cloudfoundry/uaa/commit/5c2377487bef9d716d5c8e5717df1fc00bc7b000
- https://github.com/cloudfoundry/uaa/commit/66132926f1bac0b878da5841be2f93fa5075d88f
- https://github.com/cloudfoundry/uaa/commit/b3834364ab573e9655348193780a56a602fe87b7
- https://github.com/cloudfoundry/uaa
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2016-3084 · CVE Program
- CVE-2016-3084 · NVD
- FIRST EPSS
- GHSA-fm5c-2rwc-887w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences