Apache Struts 2.3.19 to 2.3.20.2, 2.3.21 to 2.3.24.1, and 2.3.25 to 2.3.28, when Dynamic…
Priority HIGH 83CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Apache Struts 2.3.19 to 2.3.20.2, 2.3.21 to 2.3.24.1, and 2.3.25 to 2.3.28, when Dynamic Method Invocation is enabled, allow remote attackers to execute arbitrary code via vectors related to an ! (exclamation mark) operator to the REST Plugin.
Why it matters now
EPSS 0.81873 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.20.3, 2.3.24.3, 2.3.28.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.3.19 to before 2.3.20.3 | 2.3.20.3 | Patch available | GHSA-mmj6-cjj4-hpr5 |
| — | org.apache.struts:struts2-core (Maven) | 2.3.21 to before 2.3.24.3 | 2.3.24.3 | Patch available | GHSA-mmj6-cjj4-hpr5 |
| — | org.apache.struts:struts2-core (Maven) | 2.3.25 to before 2.3.28.1 | 2.3.28.1 | Patch available | GHSA-mmj6-cjj4-hpr5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.19 to before 2.3.20.3 Fixed in 2.3.20.3 Patch available GHSA-mmj6-cjj4-hpr5
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.21 to before 2.3.24.3 Fixed in 2.3.24.3 Patch available GHSA-mmj6-cjj4-hpr5
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.25 to before 2.3.28.1 Fixed in 2.3.28.1 Patch available GHSA-mmj6-cjj4-hpr5
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* | 2.3.20 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* | 2.3.20.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* | 2.3.24 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* | 2.3.24.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* | 2.3.28 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* Versions 2.3.20 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* Versions 2.3.20.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* Versions 2.3.24 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* Versions 2.3.24.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* Versions 2.3.28 Vulnerable ·Apache
Remediation
- Fix · GHSA-mmj6-cjj4-hpr5 org.apache.struts:struts2-core (Maven) Fixed in 2.3.20.3 Advisory →
- Fix · GHSA-mmj6-cjj4-hpr5 org.apache.struts:struts2-core (Maven) Fixed in 2.3.24.3 Advisory →
- Fix · GHSA-mmj6-cjj4-hpr5 org.apache.struts:struts2-core (Maven) Fixed in 2.3.28.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Satellite 5
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3087
- 2026-10-03 Alias added: GHSA-mmj6-cjj4-hpr5
References
Exploit 1
Other 6
- http://www-01.ibm.com/support/docview.wss?uid=swg21987854
- https://github.com/apache/struts/commit/6bd694b7980494c12d49ca1bf39f12aec3e03e2f
- https://github.com/apache/struts
- https://web.archive.org/web/20160616082237/http://www.securitytracker.com/id/1036017
- https://web.archive.org/web/20160728170709/http://www.securityfocus.com/bid/90960
- https://www.exploit-db.com/exploits/39919
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2016-3087 · CVE Program
- CVE-2016-3087 · NVD
- FIRST EPSS
- GHSA-mmj6-cjj4-hpr5 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-3087 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences