Read the docs
TI-2016-02607 Aliases CVE-2016-3109GHSA-cj2f-96jq-phpp

The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

Priority HIGH 65CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

Why it matters now

EPSS 0.28106 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed shopware/shopware (Packagist): 4.3.7, 5.1.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—shopware/shopware (Packagist)before 4.3.74.3.7Patch availableGHSA-cj2f-96jq-phpp
—shopware/shopware (Packagist)5.0.0 to before 5.1.55.1.5Patch availableGHSA-cj2f-96jq-phpp
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • shopware/shopware (Packagist) Vendor— Affected before 4.3.7 Fixed in 4.3.7 Patch available GHSA-cj2f-96jq-phpp
  • shopware/shopware (Packagist) Vendor— Affected 5.0.0 to before 5.1.5 Fixed in 5.1.5 Patch available GHSA-cj2f-96jq-phpp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*up to 5.1.4Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions up to 5.1.4 Vulnerable ·shopware

Remediation

  • Fix · GHSA-cj2f-96jq-phpp shopware/shopware (Packagist) Fixed in 4.3.7 Advisory →
  • Fix · GHSA-cj2f-96jq-phpp shopware/shopware (Packagist) Fixed in 5.1.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-3109
  2. 2026-10-03 Alias added: GHSA-cj2f-96jq-phpp

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
  • TI-2025-07276 Race Condition in Shopware Voucher Submission CVSS 4.0MEDIUM 6.0
See all 66 →

Sources