Read the docs
TI-2023-01895 Aliases CVE-2023-2017GHSA-7v2v-9rm4-7m8f

Improper Control of Generation of Code in Twig Rendered Views in Shopware

Priority HIGH 73CWE-1336Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1336.

Summary

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02066 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed shopware/platform (Packagist): 6.4.20.1shopware/core (Packagist): 6.4.20.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareShopware 6up to 6.4.20.0; 6.5.0.0-rc1 – 6.5.0.0-rc4—No fix listedCNA
—shopware/platform (Packagist)before 6.4.20.16.4.20.1Patch availableGHSA-7v2v-9rm4-7m8f
—shopware/core (Packagist)before 6.4.20.16.4.20.1Patch availableGHSA-7v2v-9rm4-7m8f
  • Shopware 6 Vendorshopware Affected up to 6.4.20.0; 6.5.0.0-rc1 – 6.5.0.0-rc4 Fixed in — No fix listed CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.20.1 Fixed in 6.4.20.1 Patch available GHSA-7v2v-9rm4-7m8f
  • shopware/core (Packagist) Vendor— Affected before 6.4.20.1 Fixed in 6.4.20.1 Patch available GHSA-7v2v-9rm4-7m8f

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*6.1.0 – 6.4.20.0Vulnerableshopware
cpe:2.3:a:shopware:shopware:6.5.0.0:rc1:*:*:*:*:*:*6.5.0.0 rc1Vulnerableshopware
cpe:2.3:a:shopware:shopware:6.5.0.0:rc2:*:*:*:*:*:*6.5.0.0 rc2Vulnerableshopware
cpe:2.3:a:shopware:shopware:6.5.0.0:rc3:*:*:*:*:*:*6.5.0.0 rc3Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions 6.1.0 – 6.4.20.0 Vulnerable ·shopware
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc1:*:*:*:*:*:* Versions 6.5.0.0 rc1 Vulnerable ·shopware
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc2:*:*:*:*:*:* Versions 6.5.0.0 rc2 Vulnerable ·shopware
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc3:*:*:*:*:*:* Versions 6.5.0.0 rc3 Vulnerable ·shopware

Remediation

  • Fix · GHSA-7v2v-9rm4-7m8f shopware/platform (Packagist) Fixed in 6.4.20.1 Advisory →
  • Fix · GHSA-7v2v-9rm4-7m8f shopware/core (Packagist) Fixed in 6.4.20.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2017
  2. 2026-10-03 Alias added: GHSA-7v2v-9rm4-7m8f

References

  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
  • TI-2025-07276 Race Condition in Shopware Voucher Submission CVSS 4.0MEDIUM 6.0
See all 66 →

Sources