The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute…
Priority MEDIUM 46CWE-19Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.
Why it matters now
EPSS 0.04854 92nd percentileScored 2026-11-07
Fix Fixed mercurial (PyPI): 3.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mercurial (PyPI) | before 3.7.3 | 3.7.3 | Patch available | GHSA-9vjf-jjcq-3gh7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mercurial (PyPI) Vendor— Affected before 3.7.3 Fixed in 3.7.3 Patch available GHSA-9vjf-jjcq-3gh7
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* | 22 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* | 23 | Vulnerable | Fedoraproject |
| cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* | 42.1 | Vulnerable | openSUSE |
| cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* | up to 3.7.2 | Vulnerable | Mercurial |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:a:suse:linux_enterprise_debuginfo:11:sp4:*:*:*:*:*:* | 11 sp4 | Vulnerable | SUSE |
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:11:sp4:*:*:*:*:*:* | 11 sp4 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:*:*:*:*:*:*:* | 12 | Vulnerable | SUSE |
- cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
- cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
- cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* Versions up to 3.7.2 Vulnerable ·Mercurial
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:a:suse:linux_enterprise_debuginfo:11:sp4:*:*:*:*:*:* Versions 11 sp4 Vulnerable ·SUSE
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:11:sp4:*:*:*:*:*:* Versions 11 sp4 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:*:*:*:*:*:*:* Versions 12 Vulnerable ·SUSE
Remediation
- Fix · GHSA-9vjf-jjcq-3gh7 mercurial (PyPI) Fixed in 3.7.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3630
- 2026-10-03 Alias added: GHSA-9vjf-jjcq-3gh7
References
Advisory 13
- FEDORA-2016-79604dde9f
- GLSA-201612-19
- DSA-3542
- https://selenic.com/repo/hg-stable/rev/b9714d958e89
- https://selenic.com/repo/hg-stable/rev/b6ed2505d6cf
- openSUSE-SU-2016:1016
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- SUSE-SU-2016:1011
- SUSE-SU-2016:1010
- FEDORA-2016-b7f1f8e3bf
- openSUSE-SU-2016:1073
- https://nvd.nist.gov/vuln/detail/CVE-2016-3630
Sources
- CVE-2016-3630 · CVE Program
- CVE-2016-3630 · NVD
- FIRST EPSS
- GHSA-9vjf-jjcq-3gh7 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-3630 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences