Priority HIGH 81
Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions bef…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.75597 · Published 2020-02-12 · Fixed in 3.5.3, 3.2.3 CWE-20
Priority MEDIUM 58
In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.21685 · Published 2017-06-06 · Fixed in 4.1.3 CWE-732
Priority MEDIUM 51
Mercurial prior to 4.3 did not adequately sanitize hostnames passed to ssh, leading to possible shell-injection attacks.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06543 · Published 2017-10-04 · Partial fix · 4.3 CWE-78
Priority MEDIUM 51
In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06331 · Published 2017-12-07 · Partial fix · 4.4.1 CWE-78
Priority MEDIUM 47
mpatch.c in Mercurial before 4.6.1 mishandles integer addition and subtraction, aka OVE-20180430-0002.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02717 · Published 2018-07-06 · Partial fix · 4.6.1 CWE-190
Priority MEDIUM 46
The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.04854 · Published 2016-04-13 · Fixed in 3.7.3 CWE-19
Priority MEDIUM 46
Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted name when converting a Git repository.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.04953 · Published 2016-04-13 · Partial fix · 3.7.3 CWE-20
Priority MEDIUM 46
Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.05405 · Published 2016-04-13 · Fixed in 3.7.3 CWE-20
Priority MEDIUM 44
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.02668 · Published 2018-03-14 · Partial fix · 4.5.1 CWE-732
Priority MEDIUM 43
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.02007 · Published 2018-10-04 · Fixed in 4.7.2 CWE-125
Priority MEDIUM 43
The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.02751 · Published 2016-05-09 · Partial fix · 3.8 CWE-284
Priority MEDIUM 41
Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.04948 · Published 2017-10-04 · Partial fix · 4.3.1 CWE-59
Priority MEDIUM 40
The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.04169 · Published 2015-03-31 · Partial fix · 3.2.4 CWE-20
Priority LOW 37
The mpatch_decode function in mpatch.c in Mercurial before 4.6.1 mishandles certain situations where there should be at least 12 bytes remaining after the current position in the patch data, but actually are not, aka OVE…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02145 · Published 2018-07-06 · Fixed in 4.6.1 CWE-20
Priority LOW 37
The mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02402 · Published 2018-07-06 · Partial fix · 4.6.1 CWE-20
Priority LOW 34
Directory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01901 · Published 2008-06-30 · Fixed in 1.0.2 CWE-22
Priority LOW 29
A flaw was found in Mercurial before 4.9.
CVSS 3.0MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.01362 · Published 2019-04-22 · Partial fix · 4.9 CWE-22
Priority LOW 28
Mercurial before 1.6.4 fails to verify the Common Name field of SSL certificates which allows remote attackers who acquire a certificate signed by a Certificate Authority to perform a man-in-the-middle attack.
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00821 · Published 2019-10-29 · Partial fix · 1.6.4 CWE-295
Priority LOW 28
Mercurial before 1.0.2 does not enforce the allowpull permission setting for a pull operation from hgweb, which allows remote attackers to read arbitrary files from a repository via an "hg pull" request.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02695 · Published 2008-09-27 · No fix listed CWE-264
Priority LOW 25
A vulnerability was found in Mercurial SCM 4.5.3/71.19.145.211.
CVSS 4.0MEDIUM 5.3· Network · No auth · User interaction · EPSS 0.00521 · Published 2025-03-17 · No fix listed CWE-79