Read the docs
TI-2016-03404 Aliases CVE-2016-4003GHSA-m3x6-9v6h-4g28

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as…

Priority MEDIUM 41CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in a url-encoded parameter.

Why it matters now

EPSS 0.11562 96th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.28

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.struts:struts2-core (Maven)2.0.0 to before 2.3.282.3.28Patch availableGHSA-m3x6-9v6h-4g28
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.3.28 Fixed in 2.3.28 Patch available GHSA-m3x6-9v6h-4g28

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*2.0.0 – 2.3.24.1VulnerableApache
  • cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.3.24.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-m3x6-9v6h-4g28 org.apache.struts:struts2-core (Maven) Fixed in 2.3.28 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat JBoss Fuse Service Works 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-4003
  2. 2026-10-03 Alias added: GHSA-m3x6-9v6h-4g28

References

  • TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
See all 98 →

Sources