Apache Struts 2 2.3.20 through 2.3.28.1 mishandles token validation, which allows remote…
Priority MEDIUM 44CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Apache Struts 2 2.3.20 through 2.3.28.1 mishandles token validation, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via unspecified vectors.
Why it matters now
EPSS 0.03701 89th percentileScored 2026-11-07
Fix Fixed org.apache.struts.xwork:xwork-core (Maven): 2.3.29
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts.xwork:xwork-core (Maven) | 2.3.20 to before 2.3.29 | 2.3.29 | Patch available | GHSA-38qw-j787-v8c2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts.xwork:xwork-core (Maven) Vendor— Affected 2.3.20 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-38qw-j787-v8c2
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* | 2.3.20 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* | 2.3.20.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* | 2.3.20.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* | 2.3.24 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* | 2.3.24.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* | 2.3.24.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* | 2.3.28 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:* | 2.3.28.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* Versions 2.3.20 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* Versions 2.3.20.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* Versions 2.3.20.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* Versions 2.3.24 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* Versions 2.3.24.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* Versions 2.3.24.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* Versions 2.3.28 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:* Versions 2.3.28.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-38qw-j787-v8c2 org.apache.struts.xwork:xwork-core (Maven) Fixed in 2.3.29 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Satellite 5
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4430
- 2026-10-03 Alias added: GHSA-38qw-j787-v8c2
References
Advisory 6
Other 5
- https://bugzilla.redhat.com/show_bug.cgi?id=1348249
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- https://github.com/apache/struts/commit/b28b78c062f0bf3c79793a25aab8c9b6c12bce6e
- https://github.com/apache/struts
- https://web.archive.org/web/20210123144953/http://www.securityfocus.com/bid/91281
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2016-4430 · CVE Program
- CVE-2016-4430 · NVD
- FIRST EPSS
- GHSA-38qw-j787-v8c2 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-4430 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences