Read the docs
TI-2016-03807 Aliases CVE-2016-4431GHSA-vq79-mgpx-2wx4

Apache Struts 2 2.3.20 through 2.3.28.1 allows remote attackers to bypass intended access…

Priority MEDIUM 45CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

Apache Struts 2 2.3.20 through 2.3.28.1 allows remote attackers to bypass intended access restrictions and conduct redirection attacks by leveraging a default method.

Why it matters now

EPSS 0.09755 95th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts-parent (Maven): 2.3.29

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.struts:struts-parent (Maven)2.3.20 to before 2.3.292.3.29Patch availableGHSA-vq79-mgpx-2wx4
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.struts:struts-parent (Maven) Vendor— Affected 2.3.20 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-vq79-mgpx-2wx4

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:*2.3.20VulnerableApache
cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:*2.3.20.1VulnerableApache
cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:*2.3.20.3VulnerableApache
cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:*2.3.24VulnerableApache
cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:*2.3.24.1VulnerableApache
cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:*2.3.24.3VulnerableApache
cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:*2.3.28VulnerableApache
  • cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* Versions 2.3.20 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* Versions 2.3.20.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* Versions 2.3.20.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* Versions 2.3.24 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* Versions 2.3.24.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* Versions 2.3.24.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* Versions 2.3.28 Vulnerable ·Apache

Remediation

  • Fix · GHSA-vq79-mgpx-2wx4 org.apache.struts:struts-parent (Maven) Fixed in 2.3.29 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat Enterprise Linux 5
  • Red Hat Satellite 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-4431
  2. 2026-10-03 Alias added: GHSA-vq79-mgpx-2wx4

References

  • TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
See all 98 →

Sources