Read the docs
TI-2016-03814 Aliases CVE-2016-4438GHSA-4prj-vw9j-v6pr

The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to…

Priority MEDIUM 59CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression.

Why it matters now

EPSS 0.16742 97th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.29org.apache.struts:struts2-rest-plugin (Maven): 2.3.29

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.struts:struts2-core (Maven)2.3.19 to before 2.3.292.3.29Patch availableGHSA-4prj-vw9j-v6pr
—org.apache.struts:struts2-rest-plugin (Maven)2.3.19 to before 2.3.292.3.29Patch availableGHSA-4prj-vw9j-v6pr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.19 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-4prj-vw9j-v6pr
  • org.apache.struts:struts2-rest-plugin (Maven) Vendor— Affected 2.3.19 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-4prj-vw9j-v6pr

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:*2.3.20VulnerableApache
cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:*2.3.20.1VulnerableApache
cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:*2.3.20.3VulnerableApache
cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:*2.3.24VulnerableApache
cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:*2.3.24.1VulnerableApache
cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:*2.3.24.3VulnerableApache
cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:*2.3.28VulnerableApache
  • cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* Versions 2.3.20 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* Versions 2.3.20.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* Versions 2.3.20.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* Versions 2.3.24 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* Versions 2.3.24.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* Versions 2.3.24.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* Versions 2.3.28 Vulnerable ·Apache

Remediation

  • Fix · GHSA-4prj-vw9j-v6pr org.apache.struts:struts2-core (Maven) Fixed in 2.3.29 Advisory →
  • Fix · GHSA-4prj-vw9j-v6pr org.apache.struts:struts2-rest-plugin (Maven) Fixed in 2.3.29 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat Enterprise Linux 5
  • Red Hat Satellite 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-4438
  2. 2026-10-03 Alias added: GHSA-4prj-vw9j-v6pr

References

  • TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
See all 98 →

Sources