The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.1…
Priority LOW 37CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.1 allows remote attackers to cause a denial of service via a null value for a URL field.
Why it matters now
EPSS 0.10365 95th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.29, 2.5.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.3.20 to before 2.3.29 | 2.3.29 | Patch available | GHSA-xg75-68x3-7p3q |
| — | org.apache.struts:struts2-core (Maven) | 2.5.0 to before 2.5.13 | 2.5.13 | Patch available | GHSA-xg75-68x3-7p3q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.3.20 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-xg75-68x3-7p3q
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.5.0 to before 2.5.13 Fixed in 2.5.13 Patch available GHSA-xg75-68x3-7p3q
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* | 2.3.20 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* | 2.3.20.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* | 2.3.20.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* | 2.3.24 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* | 2.3.24.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* | 2.3.24.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* | 2.3.28 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:* | 2.3.28.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:* | 2.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5:beta1:*:*:*:*:*:* | 2.5 beta1 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:* Versions 2.3.20 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:* Versions 2.3.20.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:* Versions 2.3.20.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:* Versions 2.3.24 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:* Versions 2.3.24.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:* Versions 2.3.24.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:* Versions 2.3.28 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:* Versions 2.3.28.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:* Versions 2.5 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5:beta1:*:*:*:*:*:* Versions 2.5 beta1 Vulnerable ·Apache
Remediation
- Fix · GHSA-xg75-68x3-7p3q org.apache.struts:struts2-core (Maven) Fixed in 2.3.29 Advisory →
- Fix · GHSA-xg75-68x3-7p3q org.apache.struts:struts2-core (Maven) Fixed in 2.5.13 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Satellite 5
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4465
- 2026-10-03 Alias added: GHSA-xg75-68x3-7p3q
References
Advisory 5
Other 5
- https://bugzilla.redhat.com/show_bug.cgi?id=1348253
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- https://github.com/apache/struts/commit/a0fdca138feec2c2e94eb75ca1f8b76678b4d152
- https://github.com/apache/struts/commit/eccc31ebce5430f9e91b9684c63eaaf885e603f9
- https://github.com/apache/struts
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2016-4465 · CVE Program
- CVE-2016-4465 · NVD
- FIRST EPSS
- GHSA-xg75-68x3-7p3q · GitHub Advisory Database · CC BY 4.0
- CVE-2016-4465 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences