Read the docs
TI-2016-04153 Aliases CVE-2016-4808GHSA-gp69-xcm6-ffqj

Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery)…

Priority MEDIUM 42CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.

Why it matters now

EPSS 0.01756 78th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed web2py (PyPI): 2.14.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—web2py (PyPI)before 2.14.62.14.6Patch availableGHSA-gp69-xcm6-ffqj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • web2py (PyPI) Vendor— Affected before 2.14.6 Fixed in 2.14.6 Patch available GHSA-gp69-xcm6-ffqj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:web2py:web2py:*:*:*:*:*:*:*:*up to 2.14.5Vulnerableweb2py
  • cpe:2.3:a:web2py:web2py:*:*:*:*:*:*:*:* Versions up to 2.14.5 Vulnerable ·web2py

Remediation

  • Fix · GHSA-gp69-xcm6-ffqj web2py (PyPI) Fixed in 2.14.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-4808
  2. 2026-10-03 Alias added: GHSA-gp69-xcm6-ffqj

References

  • TI-2023-24174 OS command injection in web2py CVSS 3.1CRITICAL 9.8
  • TI-2016-03363 The secure_load function in gluon/utils.py in web2py before 2.14.2 uses pickle.loads to… CVSS 3.0CRITICAL 9.8
  • TI-2016-03359 The sample web application in web2py before 2.14.2 might allow remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2016-08383 web2py before 2.14.6 does not properly check if a host is denied before verifying… CVSS 3.0CRITICAL 9.8
  • TI-2016-04151 Web2py versions 2.14.5 and below was affected by Local File Inclusion vulnerability… CVSS 3.0HIGH 7.5
  • TI-2016-03358 web2py before 2.14.1, when using the standalone version, allows remote attackers to… CVSS 3.0HIGH 7.8
See all 12 →

Sources