web2py before 2.14.6 does not properly check if a host is denied before verifying…
Priority MEDIUM 47CWE-254Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-307.
Summary
web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.
Why it matters now
EPSS 0.02608 85th percentileScored 2026-11-07
Fix Fixed web2py (PyPI): 2.14.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | web2py (PyPI) | before 2.14.6 | 2.14.6 | Patch available | GHSA-gv85-wgxc-vc56 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- web2py (PyPI) Vendor— Affected before 2.14.6 Fixed in 2.14.6 Patch available GHSA-gv85-wgxc-vc56
Remediation
- Fix · GHSA-gv85-wgxc-vc56 web2py (PyPI) Fixed in 2.14.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10321
- 2026-10-03 Alias added: GHSA-gv85-wgxc-vc56
References
More Web2py vulnerabilities
- TI-2023-24174 OS command injection in web2py CVSS 3.1CRITICAL 9.8
- TI-2016-03363 The secure_load function in gluon/utils.py in web2py before 2.14.2 uses pickle.loads to… CVSS 3.0CRITICAL 9.8
- TI-2016-03359 The sample web application in web2py before 2.14.2 might allow remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2016-04151 Web2py versions 2.14.5 and below was affected by Local File Inclusion vulnerability… CVSS 3.0HIGH 7.5
- TI-2016-04153 Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery)… CVSS 3.0HIGH 8.8
- TI-2016-03358 web2py before 2.14.1, when using the standalone version, allows remote attackers to… CVSS 3.0HIGH 7.8
Sources
- CVE-2016-10321 · CVE Program
- CVE-2016-10321 · NVD
- FIRST EPSS
- GHSA-gv85-wgxc-vc56 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences