Cross-site scripting in ADOdb
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01946 80th percentileScored 2026-11-07
Fix Fixed ADOdb (ADOdb): 5.20.6adodb/adodb-php (Packagist): 5.20.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ADOdb | ADOdb | before 5.20.6 | 5.20.6 | Patch available | CNA |
| — | adodb/adodb-php (Packagist) | before 5.20.6 | 5.20.6 | Patch available | GHSA-hhfw-xxhm-pf32 |
- ADOdb VendorADOdb Affected before 5.20.6 Fixed in 5.20.6 Patch available CNA
- adodb/adodb-php (Packagist) Vendor— Affected before 5.20.6 Fixed in 5.20.6 Patch available GHSA-hhfw-xxhm-pf32
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adodb_project:adodb:*:*:*:*:*:*:*:* | up to 5.20.5 | Vulnerable | Adodb Project |
- cpe:2.3:a:adodb_project:adodb:*:*:*:*:*:*:*:* Versions up to 5.20.5 Vulnerable ·Adodb Project
Remediation
- Fix · CNA ADOdb (ADOdb) Fixed in 5.20.6
- Fix · GHSA-hhfw-xxhm-pf32 adodb/adodb-php (Packagist) Fixed in 5.20.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4855
- 2026-10-03 Alias added: GHSA-hhfw-xxhm-pf32
References
Advisory 4
More ADOdb vulnerabilities
- TI-2025-33962 ADOdb's sqlite3 driver allows SQL injection CVSS 3.1CRITICAL 10.0
- TI-2025-29078 SQL injection in ADOdb PostgreSQL driver pg_insert_id() method CVSS 3.1CRITICAL 10.0
Sources
- CVE-2016-4855 · CVE Program
- CVE-2016-4855 · NVD
- FIRST EPSS
- GHSA-hhfw-xxhm-pf32 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-4855 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences