SQL injection in Olive Design WP-OliveCart
Priority MEDIUM 46CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
SQL injection vulnerability in the WP-OliveCart versions prior to 3.1.3 and WP-OliveCartPro versions prior to 3.1.8 allows attackers with administrator rights to execute arbitrary SQL commands via unspecified vectors.
Why it matters now
EPSS 0.01918 80th percentileScored 2026-11-07
Fix Fixed WP-OliveCart (Olive Design): 3.1.3WP-OliveCartPro (Olive Design): 3.1.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Olive Design | WP-OliveCart | before 3.1.3 | 3.1.3 | Patch available | CNA |
| Olive Design | WP-OliveCartPro | before 3.1.8 | 3.1.8 | Patch available | CNA |
- WP-OliveCart VendorOlive Design Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
- WP-OliveCartPro VendorOlive Design Affected before 3.1.8 Fixed in 3.1.8 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-olivecart:olivecart:*:*:*:*:*:wordpress:*:* | up to 3.1.2 | Vulnerable | Wp-olivecart |
| cpe:2.3:a:wp-olivecart:olivecartpro:*:*:*:*:*:wordpress:*:* | up to 3.1.7 | Vulnerable | Wp-olivecart |
- cpe:2.3:a:wp-olivecart:olivecart:*:*:*:*:*:wordpress:*:* Versions up to 3.1.2 Vulnerable ·Wp-olivecart
- cpe:2.3:a:wp-olivecart:olivecartpro:*:*:*:*:*:wordpress:*:* Versions up to 3.1.7 Vulnerable ·Wp-olivecart
Remediation
- Fix · CNA WP-OliveCart (Olive Design) Fixed in 3.1.3
- Fix · CNA WP-OliveCartPro (Olive Design) Fixed in 3.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4905
- 2026-10-03 Alias added: GHSA-2rx2-6g92-c889
References
More Olive Design vulnerabilities
- TI-2016-04247 Cross-site request forgery in Olive Design WP-OliveCart CVSS 3.0HIGH 8.8
- TI-2016-04246 Cross-site scripting in Olive Design WP-OliveCart CVSS 3.0MEDIUM 6.1
- TI-2016-06590 Cross-site scripting in Olive Diary DX CVSS 3.0MEDIUM 6.1
- TI-2016-06589 Cross-site scripting in Olive Design WEB SCHEDULE CVSS 3.0MEDIUM 6.1
- TI-2016-06588 Cross-site scripting in Olive Blog CVSS 3.0MEDIUM 6.1
- TI-2022-23512 WordPress WP-OliveCart Plugin <= 1.1.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2016-4905 · CVE Program
- CVE-2016-4905 · NVD
- FIRST EPSS
- GHSA-2rx2-6g92-c889 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences