Cross-site scripting (XSS) vulnerability in the create user functionality in the policy…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.
Why it matters now
EPSS 0.02105 81st percentileScored 2026-11-07
Fix Fixed org.apache.ranger:ranger (Maven): 0.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.ranger:ranger (Maven) | before 0.6.1 | 0.6.1 | Patch available | GHSA-rf7q-xqm3-6923 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.ranger:ranger (Maven) Vendor— Affected before 0.6.1 Fixed in 0.6.1 Patch available GHSA-rf7q-xqm3-6923
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:ranger:*:*:*:*:*:*:*:* | up to 0.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.1:*:*:*:*:*:*:* | 0.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.2:*:*:*:*:*:*:* | 0.5.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.3:*:*:*:*:*:*:* | 0.5.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.6.0:*:*:*:*:*:*:* | 0.6.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:ranger:*:*:*:*:*:*:*:* Versions up to 0.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.1:*:*:*:*:*:*:* Versions 0.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.2:*:*:*:*:*:*:* Versions 0.5.2 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.3:*:*:*:*:*:*:* Versions 0.5.3 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.6.0:*:*:*:*:*:*:* Versions 0.6.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-rf7q-xqm3-6923 org.apache.ranger:ranger (Maven) Fixed in 0.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-5395
- 2026-10-03 Alias added: GHSA-rf7q-xqm3-6923
References
More Apache Ranger vulnerabilities
- TI-2026-22888 Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder CVSS 3.1CRITICAL 9.8
- TI-2025-36701 Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator CVSS 3.1CRITICAL 9.8
- TI-2026-40283 Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator CVSS 3.1CRITICAL 9.8
- TI-2026-32358 Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation CVSS 3.1CRITICAL 9.8
- TI-2026-30817 Apache Ranger: Remote Code Execution via JDBC URL Injection CVSS 3.1CRITICAL 9.8
- TI-2026-29575 Apache Ranger: Privilege Escalation via URL Parameter CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-5395 · CVE Program
- CVE-2016-5395 · NVD
- FIRST EPSS
- GHSA-rf7q-xqm3-6923 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences