Read the docs

Apache

Records4054All Threatist records
Exploited (KEV)47In CISA KEV
CVSS critical776CVSS 9.0–10.0
CVSS high1543CVSS 7.0–8.9

Exploited now

Apache records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

31 records in Ranger · all components

Priority MEDIUM 51

Remote Code Execution via JDBC URL Injection in Apache Ranger <= 2.8.0 Users are recommended to upgrade to version 2.9.0, which fixes this issue.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01289 Published 2026-08-10 No fix listed CWE-20
Priority MEDIUM 50

Privilege Escalation via URL Parameter is reported in Apache Ranger versions <= 2.8.0.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00732 Published 2026-08-10 No fix listed CWE-20
TI-2017-05312 CVE-2017-7676 · GHSA-758m-6g3q-g3hh

Improper input validation in Apache Ranger

Priority MEDIUM 49

Policy resource matcher in Apache Ranger before 0.7.1 ignores characters after '*' wildcard character - like my*test, test*.txt.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.04198 Published 2017-06-14 Fixed in 0.7.1 CWE-20
Priority MEDIUM 48

The Admin UI in Apache Ranger before 0.5.1 does not properly handle authentication requests that lack a password, which allows remote attackers to bypass authentication by leveraging knowledge of a valid username.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.03063 Published 2016-04-12 Fixed in 0.5.1 CWE-287
TI-2018-08435 CVE-2018-11778 · GHSA-c99h-fgqm-6679

Out-of-bounds write in Apache Ranger

Priority MEDIUM 45

UnixAuthenticationService in Apache Ranger 1.2.0 was updated to correctly handle user input to avoid Stack-based buffer overflow.

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.04011 Published 2018-10-05 Fixed in 1.2.0 CWE-787
Priority MEDIUM 42

Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01126 Published 2023-05-05 Fixed in 2.4.0 CWE-74
Priority LOW 39

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.00918 Published 2023-05-05 Fixed in 2.4.0 CWE-732
Priority LOW 36

Logs contain replayable JWT tokens in Apache Ranger versions <= 2.8.0 Users are recommended to upgrade to version 2.9.0, which fixes this issue.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00637 Published 2026-08-10 No fix listed CWE-532
Priority LOW 35

SQL injection vulnerability in the policy admin tool in Apache Ranger before 0.5.3 allows remote authenticated administrators to execute arbitrary SQL commands via the eventTime parameter to service/plugins/policies/even…

CVSS 3.0HIGH 7.2 Network High privileges No interaction EPSS 0.01884 Published 2016-06-13 Fixed in 0.5.3 CWE-89
TI-2019-09244 CVE-2019-12397 · GHSA-fpqp-v323-44xv

Cross-site scripting in Apache Ranger

Priority LOW 33

Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue.

CVSS 3.0MEDIUM 6.1 Network No auth User interaction EPSS 0.02965 Published 2019-08-08 Fixed in 2.0.0 CWE-79
Priority LOW 33

In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password for users with "admin" role.

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.02071 Published 2017-10-13 Fixed in 0.6.2 CWE-255
Load more
Open these records in search →