Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.
Priority LOW 35CWE-91Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.
Why it matters now
EPSS 0.01208 68th percentileScored 2026-11-07
Fix Fixed ruby-saml (RubyGems): 1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ruby-saml (RubyGems) | before 1.3.0 | 1.3.0 | Patch available | GHSA-36p7-xjw8-h6f2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ruby-saml (RubyGems) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-36p7-xjw8-h6f2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:onelogin:ruby-saml:*:*:*:*:*:*:*:* | up to 1.2.0 | Vulnerable | SAML-Toolkits |
- cpe:2.3:a:onelogin:ruby-saml:*:*:*:*:*:*:*:* Versions up to 1.2.0 Vulnerable ·SAML-Toolkits
Remediation
- Fix · GHSA-36p7-xjw8-h6f2 ruby-saml (RubyGems) Fixed in 1.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-5697
- 2026-10-03 Alias added: GHSA-36p7-xjw8-h6f2
References
More SAML-Toolkits Ruby-saml vulnerabilities
- TI-2025-18946 Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2024-30458 The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector CVSS 3.1CRITICAL 10.0
- TI-2025-18945 ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2015-08083 xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and… CVSS 3.1CRITICAL 9.8
- TI-2025-40979 ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation CVSS 4.0CRITICAL 9.3
- TI-2025-40978 ruby-saml has a SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
Sources
- CVE-2016-5697 · CVE Program
- CVE-2016-5697 · NVD
- FIRST EPSS
- GHSA-36p7-xjw8-h6f2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences