SQL injection vulnerability in Pivotal Spring Data JPA before 1.9.6 (Gosling SR6) and…
Priority LOW 27CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL injection vulnerability in Pivotal Spring Data JPA before 1.9.6 (Gosling SR6) and 1.10.x before 1.10.4 (Hopper SR4), when used with a repository that defines a String query using the @Query annotation, allows attackers to execute arbitrary JPQL commands via a sort instance with a function call.
Why it matters now
EPSS 0.00822 57th percentileScored 2026-11-07
Fix Fixed org.springframework.data:spring-data-jpa (Maven): 1.9.6, 1.10.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.springframework.data:spring-data-jpa (Maven) | before 1.9.6 | 1.9.6 | Patch available | GHSA-xr4v-28rm-pvgw |
| — | org.springframework.data:spring-data-jpa (Maven) | 1.10.0 to before 1.10.4 | 1.10.4 | Patch available | GHSA-xr4v-28rm-pvgw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.springframework.data:spring-data-jpa (Maven) Vendor— Affected before 1.9.6 Fixed in 1.9.6 Patch available GHSA-xr4v-28rm-pvgw
- org.springframework.data:spring-data-jpa (Maven) Vendor— Affected 1.10.0 to before 1.10.4 Fixed in 1.10.4 Patch available GHSA-xr4v-28rm-pvgw
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:spring_data_jpa:*:*:*:*:*:*:*:* | up to 1.9.4 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:spring_data_jpa:1.10.2:*:*:*:*:*:*:* | 1.10.2 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:pivotal_software:spring_data_jpa:*:*:*:*:*:*:*:* Versions up to 1.9.4 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:spring_data_jpa:1.10.2:*:*:*:*:*:*:* Versions 1.10.2 Vulnerable ·Spring by Pivotal
Remediation
- Fix · GHSA-xr4v-28rm-pvgw org.springframework.data:spring-data-jpa (Maven) Fixed in 1.9.6 Advisory →
- Fix · GHSA-xr4v-28rm-pvgw org.springframework.data:spring-data-jpa (Maven) Fixed in 1.10.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6652
- 2026-10-03 Alias added: GHSA-xr4v-28rm-pvgw
References
Sources
- CVE-2016-6652 · CVE Program
- CVE-2016-6652 · NVD
- FIRST EPSS
- GHSA-xr4v-28rm-pvgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences