Credentials management flaw in Apache Ranger
Priority LOW 33CWE-255Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password for users with "admin" role.
Why it matters now
EPSS 0.02071 81st percentileScored 2026-11-07
Fix Fixed org.apache.ranger:ranger (Maven): 0.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Ranger | 0.5.x; 0.6.0; 0.6.1 | — | No fix listed | CNA |
| — | org.apache.ranger:ranger (Maven) | before 0.6.2 | 0.6.2 | Patch available | GHSA-vhxc-8jjq-859j |
- Apache Ranger VendorApache Affected 0.5.x; 0.6.0; 0.6.1 Fixed in — No fix listed CNA
- org.apache.ranger:ranger (Maven) Vendor— Affected before 0.6.2 Fixed in 0.6.2 Patch available GHSA-vhxc-8jjq-859j
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:ranger:0.4.0:*:*:*:*:*:*:* | 0.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.0:*:*:*:*:*:*:* | 0.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.1:*:*:*:*:*:*:* | 0.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.2:*:*:*:*:*:*:* | 0.5.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.5.3:*:*:*:*:*:*:* | 0.5.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.6.0:*:*:*:*:*:*:* | 0.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:ranger:0.6.1:*:*:*:*:*:*:* | 0.6.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:ranger:0.4.0:*:*:*:*:*:*:* Versions 0.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.0:*:*:*:*:*:*:* Versions 0.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.1:*:*:*:*:*:*:* Versions 0.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.2:*:*:*:*:*:*:* Versions 0.5.2 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.5.3:*:*:*:*:*:*:* Versions 0.5.3 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.6.0:*:*:*:*:*:*:* Versions 0.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:ranger:0.6.1:*:*:*:*:*:*:* Versions 0.6.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-vhxc-8jjq-859j org.apache.ranger:ranger (Maven) Fixed in 0.6.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6815
- 2026-10-03 Alias added: GHSA-vhxc-8jjq-859j
References
More Apache Ranger vulnerabilities
- TI-2026-22888 Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder CVSS 3.1CRITICAL 9.8
- TI-2025-36701 Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator CVSS 3.1CRITICAL 9.8
- TI-2026-40283 Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator CVSS 3.1CRITICAL 9.8
- TI-2026-32358 Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation CVSS 3.1CRITICAL 9.8
- TI-2026-30817 Apache Ranger: Remote Code Execution via JDBC URL Injection CVSS 3.1CRITICAL 9.8
- TI-2026-29575 Apache Ranger: Privilege Escalation via URL Parameter CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-6815 · CVE Program
- CVE-2016-6815 · NVD
- FIRST EPSS
- GHSA-vhxc-8jjq-859j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences