Cross-site request forgery in Apache Brooklyn
Priority MEDIUM 41CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site request forgery (CSRF), which could permit a malicious web site to produce a link which, if clicked whilst a user is logged in to Brooklyn, would cause the server to execute the attacker's commands as the user. There is known to be a proof-of-concept exploit using this vulnerability.
Why it matters now
EPSS 0.01318 70th percentileScored 2026-11-07
Fix Fixed org.apache.brooklyn:brooklyn-rest-resources (Maven): 0.10.0org.apache.brooklyn:brooklyn-jsgui (Maven): 0.10.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Brooklyn | 0.9.0 and all prior versions | — | No fix listed | CNA |
| — | org.apache.brooklyn:brooklyn-rest-resources (Maven) | before 0.10.0 | 0.10.0 | Patch available | GHSA-g2hf-g7fh-vg92 |
| — | org.apache.brooklyn:brooklyn-jsgui (Maven) | before 0.10.0 | 0.10.0 | Patch available | GHSA-g2hf-g7fh-vg92 |
- Apache Brooklyn VendorApache Affected 0.9.0 and all prior versions Fixed in — No fix listed CNA
- org.apache.brooklyn:brooklyn-rest-resources (Maven) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-g2hf-g7fh-vg92
- org.apache.brooklyn:brooklyn-jsgui (Maven) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-g2hf-g7fh-vg92
Remediation
- Fix · GHSA-g2hf-g7fh-vg92 org.apache.brooklyn:brooklyn-rest-resources (Maven) Fixed in 0.10.0 Advisory →
- Fix · GHSA-g2hf-g7fh-vg92 org.apache.brooklyn:brooklyn-jsgui (Maven) Fixed in 0.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8737
- 2026-10-03 Alias added: GHSA-g2hf-g7fh-vg92
References
More Apache Brooklyn vulnerabilities
- TI-2016-07201 Deserialization of untrusted data in Apache Brooklyn CVSS 3.0HIGH 8.8
- TI-2017-02381 Cross-site scripting in Apache Brooklyn CVSS 3.0MEDIUM 5.4
Sources
- CVE-2016-8737 · CVE Program
- CVE-2016-8737 · NVD
- FIRST EPSS
- GHSA-g2hf-g7fh-vg92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences