Cross-site scripting in Apache Brooklyn
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site scripting where one authenticated user can cause scripts to run in the browser of another user authorized to access the first user's resources. This is due to improper escaping of server-side content. There is known to be a proof-of-concept exploit using this vulnerability.
Why it matters now
EPSS 0.02224 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.brooklyn:brooklyn (Maven): 0.10.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Brooklyn | 0.9.0 and all prior versions | — | No fix listed | CNA |
| — | org.apache.brooklyn:brooklyn (Maven) | before 0.10.0 | 0.10.0 | Patch available | GHSA-j3g9-3fvv-gqfp |
- Apache Brooklyn VendorApache Affected 0.9.0 and all prior versions Fixed in — No fix listed CNA
- org.apache.brooklyn:brooklyn (Maven) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-j3g9-3fvv-gqfp
Remediation
- Fix · GHSA-j3g9-3fvv-gqfp org.apache.brooklyn:brooklyn (Maven) Fixed in 0.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-3165
- 2026-10-03 Alias added: GHSA-j3g9-3fvv-gqfp
References
More Apache Brooklyn vulnerabilities
- TI-2016-07201 Deserialization of untrusted data in Apache Brooklyn CVSS 3.0HIGH 8.8
- TI-2016-07194 Cross-site request forgery in Apache Brooklyn CVSS 3.0HIGH 8.8
Sources
- CVE-2017-3165 · CVE Program
- CVE-2017-3165 · NVD
- FIRST EPSS
- GHSA-j3g9-3fvv-gqfp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences