Improper input validation in Apache Struts
Priority LOW 32CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Apache Struts 2.5 through 2.5.5, if an application allows entering a URL in a form field and the built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL.
Why it matters now
EPSS 0.03259 88th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.5.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.5 - 2.5.5 | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.5.0 to before 2.5.13 | 2.5.13 | Patch available | GHSA-86vq-8qhc-5rqw |
- Apache Struts VendorApache Affected 2.5 - 2.5.5 Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.5.0 to before 2.5.13 Fixed in 2.5.13 Patch available GHSA-86vq-8qhc-5rqw
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:* | 2.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:* Versions 2.5 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Apache
Remediation
- Fix · GHSA-86vq-8qhc-5rqw org.apache.struts:struts2-core (Maven) Fixed in 2.5.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8738
- 2026-10-03 Alias added: GHSA-86vq-8qhc-5rqw
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2016-8738 · CVE Program
- CVE-2016-8738 · NVD
- FIRST EPSS
- GHSA-86vq-8qhc-5rqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences