Read the docs
TI-2016-08118 Aliases CVE-2016-10033GHSA-5f37-gxvh-23v6

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow…

Priority CRITICAL 100Exploited in the wildCWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-88.

Summary

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.

Why it matters now

Exploitation Active In CISA KEV since 2025-07-07CISA due date 2025-07-28
EPSS 0.99714 99th percentileScored 2026-11-07
Public exploit Yes 12 exploit referencesTagged by NVD and the CNA
Fix Fixed phpmailer/phpmailer (Packagist): 5.2.18

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmailer/phpmailer (Packagist)5.0.0 to before 5.2.185.2.18Patch availableGHSA-5f37-gxvh-23v6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmailer/phpmailer (Packagist) Vendor— Affected 5.0.0 to before 5.2.18 Fixed in 5.2.18 Patch available GHSA-5f37-gxvh-23v6

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:*before 5.2.18VulnerablePhpmailer Project
cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*up to 4.7VulnerableWordPress
cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*1.5.0 – 3.6.5VulnerableJoomla!
  • cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* Versions before 5.2.18 Vulnerable ·Phpmailer Project
  • cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions up to 4.7 Vulnerable ·WordPress
  • cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* Versions 1.5.0 – 3.6.5 Vulnerable ·Joomla!

Remediation

  • Fix · GHSA-5f37-gxvh-23v6 phpmailer/phpmailer (Packagist) Fixed in 5.2.18 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2025-07-07 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2016-10033
  3. 2026-10-03 Alias added: GHSA-5f37-gxvh-23v6

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 777 →

Sources