The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmailer/phpmailer (Packagist) | 5.0.0 to before 5.2.20 | 5.2.20 | Patch available | GHSA-4pc3-96mx-wwc8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmailer/phpmailer (Packagist) Vendor— Affected 5.0.0 to before 5.2.20 Fixed in 5.2.20 Patch available GHSA-4pc3-96mx-wwc8
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* | before 5.2.20 | Vulnerable | Phpmailer Project |
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | up to 4.7 | Vulnerable | WordPress |
| cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* | 1.5.0 – 3.6.5 | Vulnerable | Joomla! |
- cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* Versions before 5.2.20 Vulnerable ·Phpmailer Project
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions up to 4.7 Vulnerable ·WordPress
- cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* Versions 1.5.0 – 3.6.5 Vulnerable ·Joomla!
Remediation
- Fix · GHSA-4pc3-96mx-wwc8 phpmailer/phpmailer (Packagist) Fixed in 5.2.20 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10045
- 2026-10-03 Alias added: GHSA-4pc3-96mx-wwc8
References
Exploit 6
Patch 4
- [oss-security] 20161228 Re: PHPMailer < 5.2.18 Remote Code Execution [updated advisory] [CVE-2016-10033]
- https://github.com/PHPMailer/PHPMailer/wiki/About-the-CVE-2016-10033-and-CVE-2016-10045-vulnerabilities
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.20
- 20161227 PHPMailer < 5.2.20 Remote Code Execution PoC 0day Exploit (CVE-2016-10045) (Bypass of the CVE-2016-1033 patch)
Advisory 2
Other 6
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-4pc3-96mx-wwc8
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2016-10045.yaml
- https://github.com/PHPMailer/PHPMailer
- https://www.exploit-db.com/exploits/40969
- https://www.exploit-db.com/exploits/40986
- https://www.exploit-db.com/exploits/42221
Sources
- CVE-2016-10045 · CVE Program
- CVE-2016-10045 · NVD
- FIRST EPSS
- GHSA-4pc3-96mx-wwc8 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-10045 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences