Read the docs
TI-2016-08218 Aliases CVE-2016-10142GHSA-4jqq-7wwq-485f

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too…

Priority MEDIUM 42CWE-17Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.

Summary

An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.

Why it matters now

EPSS 0.02803 86th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ietf:ipv6:-:*:*:*:*:*:*:*not specified by NVDVulnerableIETF
  • cpe:2.3:a:ietf:ipv6:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·IETF

Remediation

Red Hat 1 advisory

  • RHSA-2017:0817 Released 2017-03-21 · Red Hat rating Moderate
    kernel security, bug fix, and enhancement update
    • Red Hat Enterprise Linux Desktop (v. 6) kernel-2.6.32-696.el6, kernel-abi-whitelists-2.6.32-696.el6, kernel-debug-2.6.32-696.el6 +6
    • Red Hat Enterprise Linux Desktop Optional (v. 6) python-perf-2.6.32-696.el6
    • Red Hat Enterprise Linux HPC Node (v. 6) kernel-2.6.32-696.el6, kernel-abi-whitelists-2.6.32-696.el6, kernel-debug-2.6.32-696.el6 +6
    • Red Hat Enterprise Linux HPC Node Optional (v. 6) python-perf-2.6.32-696.el6
    • Red Hat Enterprise Linux Server (v. 6) kernel-2.6.32-696.el6, kernel-abi-whitelists-2.6.32-696.el6, kernel-bootwrapper-2.6.32-696.el6 +9
    • Red Hat Enterprise Linux Server Optional (v. 6) python-perf-2.6.32-696.el6
    • Red Hat Enterprise Linux Workstation (v. 6) kernel-2.6.32-696.el6, kernel-abi-whitelists-2.6.32-696.el6, kernel-debug-2.6.32-696.el6 +6
    • Red Hat Enterprise Linux Workstation Optional (v. 6) python-perf-2.6.32-696.el6

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux Desktop (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux Desktop Optional (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux HPC Node (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux HPC Node Optional (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux Server Optional (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux Workstation (v. 6)Fixed RHSA-2017:0817
Red Hat Enterprise Linux Workstation Optional (v. 6)Fixed RHSA-2017:0817
Not affected: 4 products
  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise MRG 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10142
  2. 2026-10-03 Alias added: GHSA-4jqq-7wwq-485f

References

  • TI-2007-02160 The IPv6 protocol allows remote attackers to cause a denial of service via crafted IPv6… CVSS 2.0HIGH 7.8
  • TI-2025-16831 IPv6-in-IPv4 tunneling (RFC 4213) allows an attacker to spoof and route traffic via an exposed network interface. CVSS 3.1MEDIUM 6.5
  • TI-2025-16830 Improper verification of communication channel in IETF IPv6 CVSS 3.1MEDIUM 6.5

Sources