Sensitive information in log files in Elastic Logstash
Priority LOW 31CWE-532Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-532.
Summary
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
Why it matters now
EPSS 0.01092 65th percentileScored 2026-11-07
Fix Fixed Logstash (Elastic): 5.0.1logstash-core (RubyGems): 5.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Logstash | before 5.0.1 | 5.0.1 | Patch available | CNA |
| — | logstash-core (RubyGems) | before 5.0.1 | 5.0.1 | Patch available | GHSA-3gg4-6hqg-2vjx |
- Logstash VendorElastic Affected before 5.0.1 Fixed in 5.0.1 Patch available CNA
- logstash-core (RubyGems) Vendor— Affected before 5.0.1 Fixed in 5.0.1 Patch available GHSA-3gg4-6hqg-2vjx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elasticsearch:output_plugin:*:*:*:*:*:logstash:*:* | up to 5.0.0 | Vulnerable | Elasticsearch |
- cpe:2.3:a:elasticsearch:output_plugin:*:*:*:*:*:logstash:*:* Versions up to 5.0.0 Vulnerable ·Elasticsearch
Remediation
- Fix · CNA Logstash (Elastic) Fixed in 5.0.1
- Fix · GHSA-3gg4-6hqg-2vjx logstash-core (RubyGems) Fixed in 5.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10362
- 2026-10-03 Alias added: GHSA-3gg4-6hqg-2vjx
References
More Elastic vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
Sources
- CVE-2016-10362 · CVE Program
- CVE-2016-10362 · NVD
- FIRST EPSS
- GHSA-3gg4-6hqg-2vjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences