Priority HIGH 67
Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.94788 · Published 2015-08-17 · Fixed in 1.6.1 CWE-22
Priority MEDIUM 45
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.3316 · Published 2015-05-01 · Partial fix · 1.4.5, 1.5.2 CWE-22
Priority MEDIUM 40
The snapshot API in Elasticsearch before 1.6.0 when another application exists on the system that can read Lucene files and execute code from them, is accessible by the attacker, and the Java VM on which Elasticsearch is…
CVSS 3.0HIGH 7.5· Network · Low privileges · No interaction · EPSS 0.0445 · Published 2017-08-09 · Partial fix · 1.6.0 CWE-264
Priority LOW 38
Logstash 1.5.x before 1.5.3 and 1.4.x before 1.4.4 allows remote attackers to read communications between Logstash Forwarder agent and Logstash server.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02462 · Published 2017-06-27 · No fix listed CWE-200
Priority LOW 36
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01436 · Published 2017-12-08 · Fixed in 5.6.4, 6.0.0 CWE-404
Priority LOW 34
The init script in the Gentoo app-admin/logstash-bin package before 5.5.3 and 5.6.x before 5.6.1 has "chown -R" calls for user-writable directory trees, which allows local users to gain privileges by leveraging access to…
CVSS 3.0HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00347 · Published 2017-09-25 · No fix listed CWE-732
Priority LOW 33
Improper Validation of Array Index (CWE-129) in the PostgreSQL protocol parser in Packetbeat can lead Denial of Service via Input Data Manipulation (CAPEC-153).
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00508 · Published 2026-02-26 · No fix listed CWE-129
Priority LOW 32
In Kibana versions before 6.8.11 and 7.8.1 the region map visualization in contains a stored XSS flaw.
CVSS 3.1MEDIUM 6.7· Network · Low privileges · User interaction · EPSS 0.0122 · Published 2020-07-27 · Fix deferred CWE-79
Priority LOW 31
Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.
CVSS 3.0MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.01092 · Published 2017-06-16 · Fixed in 5.0.1 CWE-532
Priority LOW 30
Allocation of resources without limits or throttling (CWE-770) allows an unauthenticated remote attacker to cause excessive allocation (CAPEC-130) of memory and CPU via the integration of malicious IPv4 fragments, leadin…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00412 · Published 2025-12-18 · Fixed in 8.19.9, 9.1.9 +2 CWE-770
Priority LOW 29
Improper Bounds Check (CWE-787) in Packetbeat can allow a remote unauthenticated attacker to exploit a Buffer Overflow (CAPEC-100) and reliably crash the application or cause significant resource exhaustion via a single…
CVSS 3.1MEDIUM 6.5· Adjacent network · No auth · No interaction · EPSS 0.00458 · Published 2025-12-18 · No fix listed CWE-787
Priority LOW 29
Kibana versions prior to 5.6.1 had a cross-site scripting (XSS) vulnerability in Timelion that could allow an attacker to obtain sensitive information from or perform destructive actions on behalf of other Kibana users.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01071 · Published 2017-09-28 · No fix listed CWE-79
Priority LOW 29
Logstash 1.4.x before 1.4.5 and 1.5.x before 1.5.4 with Lumberjack output or the Logstash forwarder does not validate SSL/TLS certificates from the Logstash server, which might allow attackers to obtain sensitive informa…
CVSS 3.0MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.01219 · Published 2017-08-09 · No fix listed CWE-295
Priority LOW 28
Out-of-bounds read (CWE-125) allows an unauthenticated remote attacker to perform a buffer overflow (CAPEC-100) via the NFS protocol dissector, leading to a denial-of-service (DoS) through a reliable process crash when h…
CVSS 3.1MEDIUM 6.5· Adjacent network · No auth · No interaction · EPSS 0.00248 · Published 2025-12-18 · No fix listed CWE-125
Priority LOW 27
The client-forwarder in Elastic Cloud Enterprise versions prior to 1.0.2 do not properly encrypt traffic to ZooKeeper.
CVSS 3.0MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00573 · Published 2017-09-28 · No fix listed CWE-319
Priority LOW 25
Improper Validation of Array Index (CWE-129) in multiple protocol parser components in Packetbeat can lead Denial of Service via Input Data Manipulation (CAPEC-153).
CVSS 3.1MEDIUM 5.7· Adjacent network · Low privileges · No interaction · EPSS 0.00238 · Published 2026-03-19 · Fixed in 7.0.0-alpha2.0.20260126223743-dec1b31111ec CWE-129
Priority LOW 25
The Reporting feature in X-Pack in versions prior to 5.5.2 and standalone Reporting plugin versions versions prior to 2.4.6 had an impersonation vulnerability.
CVSS 3.0MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00695 · Published 2017-08-18 · Fixed in 5.5.2 CWE-522
Priority LOW 24
Kibana versions before 6.8.11 and 7.8.1 contain a denial of service (DoS) flaw in Timelion.
CVSS 3.1MEDIUM 4.8· Network · Low privileges · User interaction · EPSS 0.01085 · Published 2020-07-27 · Fix deferred CWE-185
Priority LOW 24
Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02023 · Published 2014-10-10 · Partial fix · 1.4.0.Beta1 CWE-79