Read the docs
TI-2016-08414 Aliases CVE-2016-10363GHSA-x36p-26r2-96m6

Logstash versions prior to 2.3.3, when using the Netflow Codec plugin, a remote attacker…

Priority LOW 36CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-248.

Summary

Logstash versions prior to 2.3.3, when using the Netflow Codec plugin, a remote attacker crafting malicious Netflow v5, Netflow v9 or IPFIX packets could perform a denial of service attack on the Logstash instance. The errors resulting from these crafted inputs are not handled by the codec and can cause the Logstash process to exit.

Why it matters now

EPSS 0.01533 74th percentileScored 2026-11-07
Fix Fixed Logstash (Elastic): 2.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElasticLogstashbefore 2.3.32.3.3Patch availableCNA
  • Logstash VendorElastic Affected before 2.3.3 Fixed in 2.3.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elastic:logstash:*:*:*:*:*:*:*:*up to 2.3.2VulnerableElastic
  • cpe:2.3:a:elastic:logstash:*:*:*:*:*:*:*:* Versions up to 2.3.2 Vulnerable ·Elastic

Remediation

  • Fix · CNA Logstash (Elastic) Fixed in 2.3.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10363
  2. 2026-10-03 Alias added: GHSA-x36p-26r2-96m6

References

  • TI-2019-05366 Information disclosure through error messages in Elastic Logstash CVSS 3.1CRITICAL 9.8
  • TI-2026-25862 Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write CVSS 3.1CRITICAL 9.8
  • TI-2014-03539 Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to… CVSS 2.0HIGH 7.5
  • TI-2015-04531 Logstash 1.5.x before 1.5.3 and 1.4.x before 1.4.4 allows remote attackers to read… CVSS 3.0HIGH 7.5
  • TI-2019-05374 Uncontrolled resource consumption in Elastic Logstash CVSS 3.1HIGH 7.5
  • TI-2023-25173 Logstash Insertion of Sensitive Information into Log File CVSS 3.1HIGH 8.4
See all 12 →

Sources