Cross-site scripting in HackerOne marked node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
marked is an application that is meant to parse and compile markdown. Due to the way that marked 0.3.5 and earlier parses input, specifically HTML entities, it's possible to bypass marked's content injection protection (`sanitize: true`) to inject a `javascript:` URL. This flaw exists because `&#xNNanything;` gets parsed to what it could and leaves the rest behind, resulting in just `anything;` being left.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | marked node module | up to 0.3.5 | — | No fix listed | CNA |
| — | marked (npm) | before 0.3.6 | 0.3.6 | Patch available | GHSA-vfvf-mqq8-rwqc |
- marked node module VendorHackerOne Affected up to 0.3.5 Fixed in — No fix listed CNA
- marked (npm) Vendor— Affected before 0.3.6 Fixed in 0.3.6 Patch available GHSA-vfvf-mqq8-rwqc
Remediation
- Fix · GHSA-vfvf-mqq8-rwqc marked (npm) Fixed in 0.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10531
- 2026-10-03 Alias added: GHSA-vfvf-mqq8-rwqc
References
Advisory 3
More markedjs Marked vulnerabilities
- TI-2026-30197 Marked: OOM Denial of Service via Infinite Recursion in marked Tokenizer CVSS 4.0HIGH 8.7
- TI-2022-06057 Exponential catastrophic backtracking (ReDoS) in marked CVSS 3.1HIGH 7.5
- TI-2022-06056 Cubic catastrophic backtracking (ReDoS) in marked CVSS 3.1HIGH 7.5
- TI-2018-15336 Regular Expression Denial of Service (ReDoS) in markedjs/marked CVSS 4.0MEDIUM 6.9
- TI-2015-07284 The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service… CVSS 3.1HIGH 7.5
- TI-2021-04406 Denial of Service in Marked CVSS 3.1HIGH 7.5
Sources
- CVE-2016-10531 · CVE Program
- CVE-2016-10531 · NVD
- FIRST EPSS
- GHSA-vfvf-mqq8-rwqc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences